Closing RRP window - visual lag

This forum is for discussing the Reason Rack Plugin, the version of the Reason rack that runs as a VST3, AU, AAX in other DAWs.
User avatar
bjmatt
Posts: 25
Joined: 05 May 2015
Location: Budapest

Post 07 Jul 2022

Hi All!

I've bit the bullet and upgraded to v12 and noticed that the new rendering engine introduced a minor lag or delay when hiding the plugin. I have tested it in Studio One and Reaper, and the lag is present in both of them. Then I have tested with R11, there it closes immediately, no lag at all. During this "lag" both the host and the RRP gui is "frozen".

I have also tested with closing via host keycommands and the plugin window close button, but didn't make a difference.

This is a minor thing, it only affects the graphical rendering, audio playback is totally fine, I'm just curious if it is a known behavior or something on my side, maybe video card related. I'm using a Lenovo laptop with an AMD CPU and it's integrated graphics chip. The OS is Win10.

R12:


R11:

User avatar
jam-s
Posts: 3004
Joined: 17 Apr 2015
Location: Aachen, Germany

Post 07 Jul 2022

I suppose this might come from the new GUI rendering using an opengl context which has to be closed properly to not leak resources. Perhaps they could implement the cleanup in a non-blocking way and just quickly move the window off-screen first so it does not block the view.

I think reporting this a a bug/regression would be a good thing to do.

User avatar
bjmatt
Posts: 25
Joined: 05 May 2015
Location: Budapest

Post 16 Jul 2022

Thanks for the response! I have reported it as bug.

I was hoping for a few responses here, to see if it's just my video card, or it's the same on every one elses configuration, but it is, what it is. For now I switched back to R11, I'd rather have a faster workflow, than Mimic/vector graphics/Combi2.

User avatar
bjmatt
Posts: 25
Joined: 05 May 2015
Location: Budapest

Post 11 Aug 2022

I've got a response today from support, and tried based on their suggestions updating my Radeon drivers and also disabling OpenGL in Reason via a preference file, but unfortunately they didn't make a difference.

It's still not a biggie, just a little inconvenient. On the other hand I have seen a few youtube videos where the same lag happened, so it's not just me, maybe it just doesn't bother others too much.

For example in the following video at 1:18:25


Jac459
Posts: 677
Joined: 29 Mar 2022
Location: Singapore

Post 11 Aug 2022

Yeah, same here... It is maybe 1.5 seconds but still there. I have an nvidia card if it matters.
Bitwig and RRP fanboy...

phonoghosts
Posts: 9
Joined: 19 Mar 2021

Post 11 Dec 2022

Just installed Reason+ (previously R11 Suite user) and I'm getting the exact same problem. It's a real workflow killer for me.

Anyone ever find a solution?

User avatar
bjmatt
Posts: 25
Joined: 05 May 2015
Location: Budapest

Post 11 Dec 2022

phonoghosts wrote:
11 Dec 2022
Anyone ever find a solution?
I did not unfortunately. Reverted back to R11 and checking every once in a while on the release notes if something related to graphics happened. But I wouldn't hold my breath, I understand that VST3 and M1 are the current priorities.

phonoghosts
Posts: 9
Joined: 19 Mar 2021

Post 11 Dec 2022

Thanks for replying. What a shame it hasn't been fixed yet. I emailed support anyway and will see what they have to say about it.

I am also considering a return to 11 for now as the only thing I wanted was the scalable interface, so may have to go back to squinting at the tiny rack again!

User avatar
kuhliloach
Posts: 880
Joined: 09 Dec 2015

Post 11 Dec 2022

I see the delays but in Logic the main problem I'm having with RRP is it crashes randomly when I pull up the window or do things to a channel that has the RRP on it. I then have to press Recover so Logic can re-load the project.

phonoghosts
Posts: 9
Joined: 19 Mar 2021

Post 19 Dec 2022

No change in 12.5

User avatar
bjmatt
Posts: 25
Joined: 05 May 2015
Location: Budapest

Post 14 Feb 2023

12.5.1 eliminated this issue, thank you ReasonStudios! :thumbs_up:

User avatar
deeplink
Competition Winner
Posts: 1063
Joined: 08 Jul 2020
Location: Dubai / Cape Town

Post 14 Feb 2023

bjmatt wrote:
14 Feb 2023
12.5.1 eliminated this issue, thank you ReasonStudios! :thumbs_up:
Awesome
Get more Combinators at the deeplink website

phonoghosts
Posts: 9
Joined: 19 Mar 2021

Post 15 Feb 2023

Yes, support confirmed with me that this was a bug just last month, so glad to see that this update has come around so quickly.

However, I am still seeing a slight delay on closing the VST window. It's a lot quicker than it was, but it's not as instant as other plug-ins, for me. Still, it's a lot more useable now.

User avatar
bjmatt
Posts: 25
Joined: 05 May 2015
Location: Budapest

Post 15 Feb 2023

I would not generalize it as being less instant then other plugins, I think it depends on which plugin we are comparing to.

The updated version responds now faster then many others, like HALion, Pigments or Zebra. But all these are very complex applications and I guess it also does not help that I have a very basic integrated GPU in my laptop.

I also got used to disconnecting network drives before opening the DAW, I think many of the delays could be attributed to plugin browsers scanning/spinning up those drives. It wouldn't be fair to blame that on the plugins.

Anyway, I know that I tend to reach for faster plugins more often, so I appreciate it a lot that RS improved this. As a small thank you gesture, I have purchased Algoritm yesterday. :) Well, I just needed a good excuse.

  • Information
  • Who is online

    Users browsing this forum: No registered users and 0 guests