Virtual Drummer Solid - Issues/Crashes

This forum is for discussing Rack Extensions. Devs are all welcome to show off their goods.
Tweak
Posts: 50
Joined: 16 Jan 2015

Post 02 Feb 2020

Hi Folks,

Before I contact UJAM about the issues I've been having with this Rack Extension, I wondered if anyone else has been having problems? The symptoms I see are that if I try to sequence some material either using a player (typically Sequences by Robotic Bean), or the main Reason sequencer, the RE will either stop playing patterns entirely, or crash outright. If I lose sound without a crash, usually all one one-shots still function, and I can occasionally get the pattern playing back seemingly through chance when pressing keys on the UI.

Since this issue doesn't occur from the get-go, and only appears after a little time, its hard to put together solid steps to reproduce. The behaviour I see when it fails looks almost as if it gets an incoming note stuck (no MIDI release arriving?), as the UI shows that its attempting to play the sequenced note/pattern. I also occasionally have the patterns play a whole bar late from the requests I make in my sequenced notes (player or main sequencer)

I can't get more than about 5-10 minutes out of this RE without having to save/reload my song.

My next check will be to unplug my MIDI controllers to make sure they're not sending spurious messages or overloading things in a hidden way. I suspect this won't help though, as I generally don't have the RE setup to receive MIDI from these.

Would love to hear from anyone else that is seeing this problem, or any workarounds.

Cheers,
Marc

I am running MacOS Mojave, with ample RAM and DSP remaining.

steveg1bbs
Posts: 2
Joined: 01 May 2018

Post 29 Apr 2020

Hi Marc, I'm having the exact same problem, but I don't use any outboard gear, and I'm on Windows 8, also with tons of RAM and plenty of horsepower left. So it points fair and square at the VST itself.
Reason support has pointed me at the makers, UJAM, as they didn't code it themselves.
Hope that helps
Steve

gregmarksimpson
Posts: 60
Joined: 14 Jan 2020

Post 30 Apr 2020

Tweak wrote:
02 Feb 2020
Hi Folks,

Before I contact UJAM about the issues I've been having with this Rack Extension, I wondered if anyone else has been having problems? The symptoms I see are that if I try to sequence some material either using a player (typically Sequences by Robotic Bean), or the main Reason sequencer, the RE will either stop playing patterns entirely, or crash outright. If I lose sound without a crash, usually all one one-shots still function, and I can occasionally get the pattern playing back seemingly through chance when pressing keys on the UI.

Since this issue doesn't occur from the get-go, and only appears after a little time, its hard to put together solid steps to reproduce. The behaviour I see when it fails looks almost as if it gets an incoming note stuck (no MIDI release arriving?), as the UI shows that its attempting to play the sequenced note/pattern. I also occasionally have the patterns play a whole bar late from the requests I make in my sequenced notes (player or main sequencer)

I can't get more than about 5-10 minutes out of this RE without having to save/reload my song.

My next check will be to unplug my MIDI controllers to make sure they're not sending spurious messages or overloading things in a hidden way. I suspect this won't help though, as I generally don't have the RE setup to receive MIDI from these.

Would love to hear from anyone else that is seeing this problem, or any workarounds.

Cheers,
Marc

I am running MacOS Mojave, with ample RAM and DSP remaining.
Out of interest, does this issue also happen with the other Virtual Drummer REs or is it an issue specific to the Solid device?

gregmarksimpson
Posts: 60
Joined: 14 Jan 2020

Post 01 May 2020

Tweak wrote:
02 Feb 2020
Hi Folks,

Before I contact UJAM about the issues I've been having with this Rack Extension, I wondered if anyone else has been having problems? The symptoms I see are that if I try to sequence some material either using a player (typically Sequences by Robotic Bean), or the main Reason sequencer, the RE will either stop playing patterns entirely, or crash outright. If I lose sound without a crash, usually all one one-shots still function, and I can occasionally get the pattern playing back seemingly through chance when pressing keys on the UI.

Since this issue doesn't occur from the get-go, and only appears after a little time, its hard to put together solid steps to reproduce. The behaviour I see when it fails looks almost as if it gets an incoming note stuck (no MIDI release arriving?), as the UI shows that its attempting to play the sequenced note/pattern. I also occasionally have the patterns play a whole bar late from the requests I make in my sequenced notes (player or main sequencer)

I can't get more than about 5-10 minutes out of this RE without having to save/reload my song.

My next check will be to unplug my MIDI controllers to make sure they're not sending spurious messages or overloading things in a hidden way. I suspect this won't help though, as I generally don't have the RE setup to receive MIDI from these.

Would love to hear from anyone else that is seeing this problem, or any workarounds.

Cheers,
Marc

I am running MacOS Mojave, with ample RAM and DSP remaining.
Hi Tweak,

I just had a jam for a good hour with Virtual Drummer Solid RE.

Started with an empty track at 120BPM; triggering Solid using Beatmap RE for 20 minutes, then Drum Sequencer RE for a further 20 minutes and then finally using some of Solid's built-in patterns triggered with single notes from the sequencer; playing the sequencer in a loop.

I couldn't reproduce the behaviour you're experiencing. Are you definitely using the latest version from the Reason Studios shop: Version: 2.0.2 - Released: 2019-09-30

Did you hear back from UJAM and are they able to reproduce the issue at their end?

Greg

Tweak
Posts: 50
Joined: 16 Jan 2015

Post 02 May 2020

Hey, thanks for the reply.

I never did take the opportunity to contact UJAM about this, not had much time for music making, and things recently been busy and difficult. I've tried again to see if I can make this crash, and I can, a simple 9 bar loop with some notes played via Sequences player. If I leave it to run for 10 minutes, stop it, run it again for a few minutes and then stop it and start it again.

Nothing in the rack exception Sequences and Virtual Drum Solid.

Marc

  • Information
  • Who is online

    Users browsing this forum: Heater and 3 guests