Bug in Robotic Beans Euclidian?

This forum is for discussing Rack Extensions. Devs are all welcome to show off their goods.
deeplink
Posts: 395
Joined: 08 Jul 2020
Location: Dubai

Post 16 Feb 2021

Euclidian doesn't work after bypassing it.

Create Euclidian.
Play some notes.
Works as expected.
Bypass device
Unbypass device.
Still doesn't receive notes.

I've loaded a the same project a few times over the last few days. Same issue.

Windows 10 and latest version of R11.

Is it just me?

User avatar
Billy+
Posts: 2354
Joined: 09 Dec 2016

Post 16 Feb 2021

I think it's just you, I use this device quite regularly and have never seen this bug.

Are you sending notes from a midi lane or midi keyboard?
VST 2.4 MIDI It's definitely on the list of todos
Current POLL go vote now

ˁ˚ᴥ˚ˀ Time for a good long sleep ˁ˚ᴥ˚ˀ

deeplink
Posts: 395
Joined: 08 Jul 2020
Location: Dubai

Post 16 Feb 2021

Billy+ wrote:
16 Feb 2021
I think it's just you, I use this device quite regularly and have never seen this bug.

Are you sending notes from a midi lane or midi keyboard?
Midi Keyboard.

When I drag a Euclidian onto the existing one, it works as expected again.

Bizarre. Maybe it's just the project file? Never ran into a project specific bug before.

User avatar
Billy+
Posts: 2354
Joined: 09 Dec 2016

Post 16 Feb 2021

Are you making sure you've armed the track to receive the midi input?
VST 2.4 MIDI It's definitely on the list of todos
Current POLL go vote now

ˁ˚ᴥ˚ˀ Time for a good long sleep ˁ˚ᴥ˚ˀ

User avatar
challism
Moderator
Posts: 2827
Joined: 17 Jan 2015

Post 16 Feb 2021

deeplink wrote:
16 Feb 2021
Euclidian doesn't work after bypassing it.

Create Euclidian.
Play some notes.
Works as expected.
Bypass device
Unbypass device.
Still doesn't receive notes.

I've loaded a the same project a few times over the last few days. Same issue.

Windows 10 and latest version of R11.

Is it just me?
Share the Reason song file with us. I've never experienced this behavior, either. And I use Euclidean all the time. I would be interested to see your song file.

One issue I have noticed with Euclidean once in a while is it will skip the first note. But that is fixed by nudging/sliding the gates to the right just a tick or two.
~~~~~~~~~~~~~~~~~~~~~~
Players are to MIDI what synthesizers are to waveforms.

ReasonTalk Rules and Guidelines

User avatar
buddard
RE Developer
Posts: 975
Joined: 17 Jan 2015
Location: Stockholm

Post 16 Feb 2021

deeplink wrote:
16 Feb 2021
Euclidian doesn't work after bypassing it.

Create Euclidian.
Play some notes.
Works as expected.
Bypass device
Unbypass device.
Still doesn't receive notes.

I've loaded a the same project a few times over the last few days. Same issue.

Windows 10 and latest version of R11.

Is it just me?
Thanks for reporting, but I haven't been able to reproduce this issue. A couple of followup questions:
  • With "Bypass device", do you mean toggling the "Bypass All" switch in the Player bar, or are you referring to switching the device on and off with the On button?
  • And with "Still doesn't receive notes", do you mean that notes you play are passed through the device as they are played, or aren't they passed through at all?
  • Also, did you make sure that the instrument device (below the player(s)) has the MIDI focus, and not Euclidean itself?
  • And if the focus is set correctly, does it light up the "green bar" in the focus indicator when you play notes on your keyboard? (See screenshot below):

MIDI_Focus.png
You do not have the required permissions to view the files attached to this post.

  • Information
  • Who is online

    Users browsing this forum: No registered users and 4 guests