(SOLVED) Front-8 color scheme knobs not working

This forum is for discussing Rack Extensions. Devs are all welcome to show off their goods.
User avatar
challism
Moderator
Posts: 2233
Joined: 17 Jan 2015

Post 01 Jan 2021

I love Front-8. I have kind of forgotten about it, though, and having used it for a few years. So I decided to get it out and play with it today. I noticed that the color scheme knobs aren't doing anything for the input section. Has anybody else noticed this? It still functions as it is supposed to for the output section. This is kind of disappointing because I really loved the way I could customize the colors before. And since Front-8 is free, I wouldn't blame the developer for not fixing the issue (assuming it's a problem with Front-8... the problem could be with this version of Reason or maybe even Windows specific). Another question is how could this have happened? It worked fine in previous versions of Reason. I don't remember the last version I used it with (it's been a while since I last used it), but it's doing this in R11 now.

~~~~~~~~~~~~~~~~~~~~~~
ReasonTalk Rules and Guidelines

User avatar
Loque
Moderator
Posts: 8268
Joined: 28 Dec 2015

Post 01 Jan 2021

I just recently played around with it and thought i was doing something wrong...
:reason: 11, Win10 64Bit.

User avatar
challism
Moderator
Posts: 2233
Joined: 17 Jan 2015

Post 01 Jan 2021

Kind of a bummer.... I really liked the way I could adjust the colors. I thought that was something really special and the developer obviously put a lot of thought and effort into that feature. I guess it's only available for outputs now.

Doesn't this break backwards compatibility though? I mean, the device's code has been changed. It's basically been abandoned since it was offered for free (I've got no problems with the dev for doing that). It is Reason that has changed. So it seems as if it is Reason that broke this device.
~~~~~~~~~~~~~~~~~~~~~~
ReasonTalk Rules and Guidelines

User avatar
16161d
Posts: 35
Joined: 26 Jan 2015

Post 01 Jan 2021

I have found the issue and it doesn't seem to be a bug. The device has several colour presets, but the only preset which can be customised using the colour wheels is (5)Custom, but the default device starts with the input using (1)Rainbow A and only the output using the custom one, hence why only that was working in your example.

Set them both to (5)Custom and you can change the colours, but modifying the existing presets doesn't seem to work. It is a little confusing, I can see how having the inputs default to the theme it does make it seem a bit prettier and functional though. EDIT: You can change the themes clicking on the bracketed numbers above and below the colour wheels by the way.

User avatar
challism
Moderator
Posts: 2233
Joined: 17 Jan 2015

Post 01 Jan 2021

16161d wrote:
01 Jan 2021
I have found the issue and it doesn't seem to be a bug. The device has several colour presets, but the only preset which can be customised using the colour wheels is (5)Custom, but the default device starts with the input using (1)Rainbow A and only the output using the custom one, hence why only that was working in your example.

Set them both to (5)Custom and you can change the colours, but modifying the existing presets doesn't seem to work. It is a little confusing, I can see how having the inputs default to the theme it does make it seem a bit prettier and functional though. EDIT: You can change the themes clicking on the bracketed numbers above and below the colour wheels by the way.
Oh wow, I don't even remember ever seeing that dropdown menu before. I didn't even know this has those different themes. OK, so it does appear to ber working properly. Cool. Thanks for pointing that out to me! So glad it isn't broken (just a case of user error).
Untitled.png
You do not have the required permissions to view the files attached to this post.
~~~~~~~~~~~~~~~~~~~~~~
ReasonTalk Rules and Guidelines

  • Information
  • Who is online

    Users browsing this forum: Ahrefs [Bot], CommonCrawl [Bot], esselfortium, estuary, lecafard, Trendiction [Bot] and 3 guests