Authoriser problems (file or directory is locked)

This forum is for discussing Rack Extensions. Devs are all welcome to show off their goods.
T.G.
Posts: 30
Joined: 06 Jul 2015

Post 05 May 2020

Hi,
Just been working in reason, (updated it this morning)
I've just downloaded matchlock RE (having saved and exited reason)
Waited for updated licenses, and went to open reason only to find that the multiple REs that I had been using previously are now "missing", and indeed I get an error on startup saying that:

Failed reading rack extension data in
com.roboticbean.select.1.1.0
this rack extension installation is broken and will not be available in this session

I wasn't even using this in the session, and at least half my rack extensions are missing...

and when I go to my account to "sync all" I get an error saying "file or directory locked" in authoriser.

Please help! I'm on a Mac, running Catalina, and like I said, everything had been working fine in the new version today until I downloaded another rack extension, it seems to have completely messed up authoriser.

T.G.
Posts: 30
Joined: 06 Jul 2015

Post 05 May 2020

ok, very weird.

Just restarted computer, logged back in to my account and hit "sync all"
the robotic bean select RE installed in authoriser...very quickly and no "update license" to be seen.
quit authoriser and started reason.
All my RE's are back, and no error on startup as reported above.
very odd.
but it works now, so i don't care! ;)

if in doubt, turn it off and on again!

  • Information
  • Who is online

    Users browsing this forum: Ahrefs [Bot], CommonCrawl [Bot] and 1 guest