Sweeper & Quartet REs inside Reason 10

This forum is for discussing Rack Extensions. Devs are all welcome to show off their goods.
gregmarksimpson
Posts: 30
Joined: 14 Jan 2020

Post 21 Feb 2020

I have Reason 11 Suite but I'm having to use Reason 10 as my Mac can't be upgraded to the later version of macOS required by Reason 11.

I'm not interested in running the AU/VST Reason plugin but I am annoyed I'm missing out on a couple of REs that come with R11.

I'm happy using 10 but would really like the Sweeper & Quartet rack devices in there and I know that there's nothing technically stopping Reason Studios from putting these two devices in their store. They just released the Beat Map Player RE to the store, and I've had to buy it to get it into R10 even though I should have it for free as a R11 owner!.

Reason Studios; could you please put Sweeper & Quartet in your shop so I can buy them and use them inside Reason 10?

Best wishes,

Greg
Last edited by gregmarksimpson on 18 Mar 2020, edited 2 times in total.

User avatar
Loque
Posts: 6774
Joined: 28 Dec 2015

Post 21 Feb 2020

How can you go around the technical problems?
:reason: 11, Win10 64Bit.

gregmarksimpson
Posts: 30
Joined: 14 Jan 2020

Post 21 Feb 2020

Loque wrote:
21 Feb 2020
How can you go around the technical problems?
What technical problems? I have no technical problems, just an inability to run R11 (because it needs a newer macOS) and also an inability to buy Quartet and Sweeper from the store. Both Sweeper & Quartet were built with the same SDK as Beat Map which works in R10 fine, so there shouldn't be a technical limitation stopping Reason Studios in back-releasing these two REs into the store now R11 has been out a while.

If Reason Studios would just release them on the store, I can get them running in R10! :)

User avatar
Boombastix
Posts: 1121
Joined: 18 May 2018
Location: Bay Area, CA

Post 21 Feb 2020

gregmarksimpson wrote:
21 Feb 2020
Loque wrote:
21 Feb 2020
How can you go around the technical problems?
What technical problems? I have no technical problems, just an inability to run R11 (because it needs a newer macOS) and also an inability to buy Quartet and Sweeper from the store. Both Sweeper & Quartet were built with the same SDK as Beat Map which works in R10 fine, so there shouldn't be a technical limitation stopping Reason Studios in back-releasing these two REs into the store now R11 has been out a while.

If Reason Studios would just release them on the store, I can get them running in R10! :)
Get a VST hosting plugin that can host VST3 and put the RRP in it with Sweeper. You could make a R10 Combinator and assign the 4 dials to control sweeper w/o having to open up the nested VSTs.
10% off at Waves with link: https://www.waves.com/r/6gh2b0
Disclaimer - I get 10% as well.

gregmarksimpson
Posts: 30
Joined: 14 Jan 2020

Post 22 Feb 2020

Boombastix wrote:
21 Feb 2020
gregmarksimpson wrote:
21 Feb 2020


What technical problems? I have no technical problems, just an inability to run R11 (because it needs a newer macOS) and also an inability to buy Quartet and Sweeper from the store. Both Sweeper & Quartet were built with the same SDK as Beat Map which works in R10 fine, so there shouldn't be a technical limitation stopping Reason Studios in back-releasing these two REs into the store now R11 has been out a while.

If Reason Studios would just release them on the store, I can get them running in R10! :)
Get a VST hosting plugin that can host VST3 and put the RRP in it with Sweeper. You could make a R10 Combinator and assign the 4 dials to control sweeper w/o having to open up the nested VSTs.
I still can't do that because the RRP has the same macOS requirements as R11 app. I have to run R10. Like I said above, Beat Map RE works in R10 so it would be good of Reason Studios to make Quartet and Sweeper available as standalone REs in the store too so I can get them running in R10. As a fully licensed R11 user, it would be nice to be able to use them in my R10 studio! :)

I'm getting doubtful they'll do such a thing though...

gregmarksimpson
Posts: 30
Joined: 14 Jan 2020

Post 24 Feb 2020

gregmarksimpson wrote:
22 Feb 2020
Boombastix wrote:
21 Feb 2020


Get a VST hosting plugin that can host VST3 and put the RRP in it with Sweeper. You could make a R10 Combinator and assign the 4 dials to control sweeper w/o having to open up the nested VSTs.
I still can't do that because the RRP has the same macOS requirements as R11 app. I have to run R10. Like I said above, Beat Map RE works in R10 so it would be good of Reason Studios to make Quartet and Sweeper available as standalone REs in the store too so I can get them running in R10. As a fully licensed R11 user, it would be nice to be able to use them in my R10 studio! :)

I'm getting doubtful they'll do such a thing though...
@MattiasHG - Any chance of putting Sweeper and Quartet onto the store?

Mint
Posts: 35
Joined: 17 Nov 2019

Post 24 Feb 2020

gregmarksimpson wrote:
24 Feb 2020
gregmarksimpson wrote:
22 Feb 2020


I still can't do that because the RRP has the same macOS requirements as R11 app. I have to run R10. Like I said above, Beat Map RE works in R10 so it would be good of Reason Studios to make Quartet and Sweeper available as standalone REs in the store too so I can get them running in R10. As a fully licensed R11 user, it would be nice to be able to use them in my R10 studio! :)

I'm getting doubtful they'll do such a thing though...
@MattiasHG - Any chance of putting Sweeper and Quartet onto the store?
Yeah, that would be co0L. :puf_bigsmile:

User avatar
MrFigg
Posts: 3723
Joined: 20 Apr 2018

Post 24 Feb 2020

Mint wrote:
24 Feb 2020
gregmarksimpson wrote:
24 Feb 2020


@MattiasHG - Any chance of putting Sweeper and Quartet onto the store?
Yeah, that would be co0L. :puf_bigsmile:
Yeah. Sure. Great idea. And they can charge €69 each for them. Cynical huh?
丰2ॐ

gregmarksimpson
Posts: 30
Joined: 14 Jan 2020

Post 24 Feb 2020

MrFigg wrote:
24 Feb 2020
Mint wrote:
24 Feb 2020


Yeah, that would be co0L. :puf_bigsmile:
Yeah. Sure. Great idea. And they can charge €69 each for them. Cynical huh?
They should charge £44 for each one. As much as it's annoying that I'd have to fork out for them twice (given I already own Reason 11) I wouldn't object to paying again, as they both look like valuable devices to have in the rack and given I'm stuck running Reason 10 it would be nice to have them.

Anyone from Reason Studios reading this thread? :)

User avatar
MrFigg
Posts: 3723
Joined: 20 Apr 2018

Post 24 Feb 2020

gregmarksimpson wrote:
24 Feb 2020
MrFigg wrote:
24 Feb 2020


Yeah. Sure. Great idea. And they can charge €69 each for them. Cynical huh?
They should charge £44 for each one. As much as it's annoying that I'd have to fork out for them twice (given I already own Reason 11) I wouldn't object to paying again, as they both look like valuable devices to have in the rack and given I'm stuck running Reason 10 it would be nice to have them.

Anyone from Reason Studios reading this thread? :)
Just wondering man. Did you read the spec requirements for Reason 11 before you bought it? I mean you can’t have known that it wouldn’t run on your Mac as it was and still bought Suite anyway...right?
丰2ॐ

User avatar
joeyluck
Moderator
Posts: 6570
Joined: 15 Jan 2015

Post 24 Feb 2020

What version of macOS are you on?

The current version of macOS is 10.15 Catalina.
Reason 11 only requires 10.11 El Capitan.

Maybe your computer is compatible with 10.11?
If so, you can get 10.11 from here: https://support.apple.com/en-us/HT206886

gregmarksimpson
Posts: 30
Joined: 14 Jan 2020

Post 24 Feb 2020

MrFigg wrote:
24 Feb 2020
gregmarksimpson wrote:
24 Feb 2020


They should charge £44 for each one. As much as it's annoying that I'd have to fork out for them twice (given I already own Reason 11) I wouldn't object to paying again, as they both look like valuable devices to have in the rack and given I'm stuck running Reason 10 it would be nice to have them.

Anyone from Reason Studios reading this thread? :)
Just wondering man. Did you read the spec requirements for Reason 11 before you bought it? I mean you can’t have known that it wouldn’t run on your Mac as it was and still bought Suite anyway...right?
I read the system requirements and I knew it wouldn't run but I still bought Reason 11 Suite anyway so I could get all those Propellerhead REs added to my account at a very discounted price.

The only outstanding Reason Studio REs that I now don't have are Quartet and Sweeper. I've just been able to buy Beat Map so I know any new RE that Reason Studios currently create is technically able to run on this machine no problem. R10 has the same version of the Reason Rack SDK as R11, at least at the moment it does anyway. Reason Studios just haven't published version of Quartet and Sweeper to the store that I could buy and download to get them running on this machine

I would be happy to pay £88 for these two REs just to get a Reason Studios rack-complete R10 setup...at least until they next upgrade the Rack SDK and R10 gets deprecated at that time...
Last edited by gregmarksimpson on 24 Feb 2020, edited 1 time in total.

gregmarksimpson
Posts: 30
Joined: 14 Jan 2020

Post 24 Feb 2020

joeyluck wrote:
24 Feb 2020
What version of macOS are you on?

The current version of macOS is 10.15 Catalina.
Reason 11 only requires 10.11 El Capitan.

Maybe your computer is compatible with 10.11?
If so, you can get 10.11 from here: https://support.apple.com/en-us/HT206886
The last version of OS X this Mac can run is 10.7.5. I am still very happy with this computer, it has loads of CPU power, RAM and a large SSD in it. I can understand that Reason Studios had to up the system requirements for R11, that's fine, especially given they needed that newer tech for the Reason Plugin. But for those of us who can't upgrade beyond OS X Lion who can run Reason 10, it would be a wonderful gift if they could make the two new REs of Quartet and Sweeper available on their store as there's literally no other way I can get them running without buying a whole new computer...actually there is one way, I could Bootcamp this Mac into Windows and run Reason 11 on there, but there's absolutely no way I'm doing that as I absolutely hate Windows.

User avatar
MrFigg
Posts: 3723
Joined: 20 Apr 2018

Post 24 Feb 2020

gregmarksimpson wrote:
24 Feb 2020
MrFigg wrote:
24 Feb 2020


Just wondering man. Did you read the spec requirements for Reason 11 before you bought it? I mean you can’t have known that it wouldn’t run on your Mac as it was and still bought Suite anyway...right?
I read the system requirements and I knew it wouldn't run but I still bought Reason 11 Suite anyway so I could get all those Propellerhead REs added to my account at a very discounted price.

The only outstanding Reason Studio REs that I now don't have are Quartet and Sweeper. I've just been able to buy Beat Map so I know any new RE that Reason Studios currently create is technically able to run on this machine no problem. R10 has the same version of the Reason Rack SDK as R11, at least at the moment it does anyway. Reason Studios just haven't published version of Quartet and Sweeper to the store that I could buy and download to get them running on this machine

I would be happy to pay £88 for these two REs just to get a Reason Studios rack-complete R10 setup...at least until they next upgrade the Rack SDK and R10 gets deprecated at that time...
Sure...if you’re happy enough to buy ‘em then I’m glad you’re happy. The fact that you’ve been and bought Beat Map even though it comes with R11.2, which you own, and is available as an RE in the shop makes me a bit sad as a consumer. Did you think of asking Propellerheads and explaining your situation first. They have been pretty decen in the past and may have sorted you out with Beat Map RE. I don’t know this for sure of course as doing this would also mean that if you ever sold your Reason 11 license you’d still have the RE on your account. Personally I’d have chanced my arm as it sounds as if you’ve already shelled out a whole load of cash and appear to be willing to shell out even more for stuff you’ve essentially already paid for.
丰2ॐ

Mint
Posts: 35
Joined: 17 Nov 2019

Post 24 Feb 2020

MrFigg wrote:
24 Feb 2020

Yeah. Sure. Great idea. And they can charge €69 each for them. Cynical huh?
Yeah well done! "You can take the bloke out of glesgie but you can't take the......bla blah".

I'm cool with paying - if need be. Reason's more than paid for it's self over the years and I'm not necessarily speaking monetarily. I'm the biggest anti capitalist on the planet but understand that people need to make a living. And I've no reason to subscribe to the veiw that Reason Studio's are out to screw every $$$ they can out of everyone.

Mint
Posts: 35
Joined: 17 Nov 2019

Post 24 Feb 2020

The way I see it because "Beat map" can be bought separately. If one upgrades to Reason 11.2, "Beat map" will appear in ones account - a bit like " :re: Drum Sequencer" does. Sooo, then you could download it into Reason 10. At least, that's what I'm hoping :roll:
Same could apply with the afore mentioned Quartet and Sweeper or SSL comp, Eq, Master comp if they make them RE shop available (it's a BIG If).

User avatar
moneykube
Posts: 2230
Joined: 15 Jan 2015

Post 24 Feb 2020

yes please and thank you.... for racks of these :exclamation:

User avatar
SoulState
Posts: 303
Joined: 15 Jan 2015

Post 24 Feb 2020

MrFigg wrote:
24 Feb 2020
Yeah. Sure. Great idea. And they can charge €69 each for them. Cynical huh?
You sound pissed off about something that’s not even a reality.
But unfortunately you’re not alone...
There’s waaay to many guys round here can’t wait to tear down the company that makes the software they use.

Like has been quoted so many times before...You don’t have to make any purchase you don’t need or want....If RS puts stuff in the shop, just keep walking.
:reason:

User avatar
MrFigg
Posts: 3723
Joined: 20 Apr 2018

Post 24 Feb 2020

SoulState wrote:
24 Feb 2020
MrFigg wrote:
24 Feb 2020
Yeah. Sure. Great idea. And they can charge €69 each for them. Cynical huh?
You sound pissed off about something that’s not even a reality.
But unfortunately you’re not alone...
There’s waaay to many guys round here can’t wait to tear down the company that makes the software they use.

Like has been quoted so many times before...You don’t have to make any purchase you don’t need or want....If RS puts stuff in the shop, just keep walking.
Hahahahaha.
丰2ॐ

User avatar
SoulState
Posts: 303
Joined: 15 Jan 2015

Post 24 Feb 2020

Mint wrote:
24 Feb 2020
gregmarksimpson wrote:
24 Feb 2020


@MattiasHG - Any chance of putting Sweeper and Quartet onto the store?
Yeah, that would be co0L. :puf_bigsmile:
I take it you’re still on Reason 10?
:reason:

Mint
Posts: 35
Joined: 17 Nov 2019

Post 24 Feb 2020

SoulState wrote:
24 Feb 2020

I take it you’re still on Reason 10?
Yeah mate, My hardware won't support anything above Yosemite (os 10.10). Thought me and Reason would be tight for a couple more years, given that Reason system requirements for Reason 10 was only 10.7.
My thinking was when Reason 11 drops it might require os 10.9 or maybe 10.10 but alas no, it jumped to os 10.11 :puf_unhappy:

You?

Mint
Posts: 35
Joined: 17 Nov 2019

Post 24 Feb 2020

You still on 10?

User avatar
SoulState
Posts: 303
Joined: 15 Jan 2015

Post 24 Feb 2020

I'm still on 10 for similar reasons, I'm cool with that, but for how long...I know that at some point in the future Reason's going to add some magic feature that I've "gotta have", then I'm scr*wed. :?
:reason:

gregmarksimpson
Posts: 30
Joined: 14 Jan 2020

Post 25 Feb 2020

Mint wrote:
24 Feb 2020
SoulState wrote:
24 Feb 2020

I take it you’re still on Reason 10?
Yeah mate, My hardware won't support anything above Yosemite (os 10.10). Thought me and Reason would be tight for a couple more years, given that Reason system requirements for Reason 10 was only 10.7.
My thinking was when Reason 11 drops it might require os 10.9 or maybe 10.10 but alas no, it jumped to os 10.11 :puf_unhappy:

You?
This was exactly what I thought would happen too; given the system requirements of Reason did stay at 10.7 for a good while. I think the main reason for the 10.11 new requirement is more because of the AU and VST plugins than the main app. And given they've not incremented the RE SDK when they went to 11, we're in the position where brand new REs will still work on R10. Apart from, frustratingly, the two new internal REs in question which will not load in R10 and aren't on the store to buy versions that will...

I really hope someone from Reason Studios reads this and considers putting Quartet and Sweeper up on the store for those of us stuck on Reason 10 out of necessity rather than choice...especially someone like me who technically owns a license to use Beat Map, Quartet and Sweeper given I'm an R11 Suite license holder...

gregmarksimpson
Posts: 30
Joined: 14 Jan 2020

Post 26 Feb 2020

Mint wrote:
24 Feb 2020
SoulState wrote:
24 Feb 2020

I take it you’re still on Reason 10?
Yeah mate, My hardware won't support anything above Yosemite (os 10.10). Thought me and Reason would be tight for a couple more years, given that Reason system requirements for Reason 10 was only 10.7.
My thinking was when Reason 11 drops it might require os 10.9 or maybe 10.10 but alas no, it jumped to os 10.11 :puf_unhappy:

You?
Hey Mint, according to Wikipedia all Macintosh computers that can run Mountain Lion, Mavericks, or Yosemite can run El Capitan; although not all of its features will work on older computers. It sounds like you can upgrade. Apple have a publicly available full installer available for these older OS X versions these days, without the need to use the App Store. Here's the link: https://support.apple.com/en-us/HT206886

My Mac is definitely stuck at 10.7.5. Bit disappointed nobody from Propellerhead/Reason Studios has chimed in on this thread, even if it's just to say "it isn't gonna happen!".

  • Information
  • Who is online

    Users browsing this forum: CommonCrawl [Bot], Ixus and 1 guest