Virtual Drummer Solid - Issues/Crashes

This forum is for discussing Rack Extensions. Devs are all welcome to show off their goods.
Tweak
Posts: 78
Joined: 16 Jan 2015

Post 02 Feb 2020

Hi Folks,

Before I contact UJAM about the issues I've been having with this Rack Extension, I wondered if anyone else has been having problems? The symptoms I see are that if I try to sequence some material either using a player (typically Sequences by Robotic Bean), or the main Reason sequencer, the RE will either stop playing patterns entirely, or crash outright. If I lose sound without a crash, usually all one one-shots still function, and I can occasionally get the pattern playing back seemingly through chance when pressing keys on the UI.

Since this issue doesn't occur from the get-go, and only appears after a little time, its hard to put together solid steps to reproduce. The behaviour I see when it fails looks almost as if it gets an incoming note stuck (no MIDI release arriving?), as the UI shows that its attempting to play the sequenced note/pattern. I also occasionally have the patterns play a whole bar late from the requests I make in my sequenced notes (player or main sequencer)

I can't get more than about 5-10 minutes out of this RE without having to save/reload my song.

My next check will be to unplug my MIDI controllers to make sure they're not sending spurious messages or overloading things in a hidden way. I suspect this won't help though, as I generally don't have the RE setup to receive MIDI from these.

Would love to hear from anyone else that is seeing this problem, or any workarounds.

Cheers,
Marc

I am running MacOS Mojave, with ample RAM and DSP remaining.

steveg1bbs
Posts: 2
Joined: 01 May 2018

Post 29 Apr 2020

Hi Marc, I'm having the exact same problem, but I don't use any outboard gear, and I'm on Windows 8, also with tons of RAM and plenty of horsepower left. So it points fair and square at the VST itself.
Reason support has pointed me at the makers, UJAM, as they didn't code it themselves.
Hope that helps
Steve

gregmarksimpson
Posts: 60
Joined: 14 Jan 2020

Post 30 Apr 2020

Tweak wrote:
02 Feb 2020
Hi Folks,

Before I contact UJAM about the issues I've been having with this Rack Extension, I wondered if anyone else has been having problems? The symptoms I see are that if I try to sequence some material either using a player (typically Sequences by Robotic Bean), or the main Reason sequencer, the RE will either stop playing patterns entirely, or crash outright. If I lose sound without a crash, usually all one one-shots still function, and I can occasionally get the pattern playing back seemingly through chance when pressing keys on the UI.

Since this issue doesn't occur from the get-go, and only appears after a little time, its hard to put together solid steps to reproduce. The behaviour I see when it fails looks almost as if it gets an incoming note stuck (no MIDI release arriving?), as the UI shows that its attempting to play the sequenced note/pattern. I also occasionally have the patterns play a whole bar late from the requests I make in my sequenced notes (player or main sequencer)

I can't get more than about 5-10 minutes out of this RE without having to save/reload my song.

My next check will be to unplug my MIDI controllers to make sure they're not sending spurious messages or overloading things in a hidden way. I suspect this won't help though, as I generally don't have the RE setup to receive MIDI from these.

Would love to hear from anyone else that is seeing this problem, or any workarounds.

Cheers,
Marc

I am running MacOS Mojave, with ample RAM and DSP remaining.
Out of interest, does this issue also happen with the other Virtual Drummer REs or is it an issue specific to the Solid device?

gregmarksimpson
Posts: 60
Joined: 14 Jan 2020

Post 01 May 2020

Tweak wrote:
02 Feb 2020
Hi Folks,

Before I contact UJAM about the issues I've been having with this Rack Extension, I wondered if anyone else has been having problems? The symptoms I see are that if I try to sequence some material either using a player (typically Sequences by Robotic Bean), or the main Reason sequencer, the RE will either stop playing patterns entirely, or crash outright. If I lose sound without a crash, usually all one one-shots still function, and I can occasionally get the pattern playing back seemingly through chance when pressing keys on the UI.

Since this issue doesn't occur from the get-go, and only appears after a little time, its hard to put together solid steps to reproduce. The behaviour I see when it fails looks almost as if it gets an incoming note stuck (no MIDI release arriving?), as the UI shows that its attempting to play the sequenced note/pattern. I also occasionally have the patterns play a whole bar late from the requests I make in my sequenced notes (player or main sequencer)

I can't get more than about 5-10 minutes out of this RE without having to save/reload my song.

My next check will be to unplug my MIDI controllers to make sure they're not sending spurious messages or overloading things in a hidden way. I suspect this won't help though, as I generally don't have the RE setup to receive MIDI from these.

Would love to hear from anyone else that is seeing this problem, or any workarounds.

Cheers,
Marc

I am running MacOS Mojave, with ample RAM and DSP remaining.
Hi Tweak,

I just had a jam for a good hour with Virtual Drummer Solid RE.

Started with an empty track at 120BPM; triggering Solid using Beatmap RE for 20 minutes, then Drum Sequencer RE for a further 20 minutes and then finally using some of Solid's built-in patterns triggered with single notes from the sequencer; playing the sequencer in a loop.

I couldn't reproduce the behaviour you're experiencing. Are you definitely using the latest version from the Reason Studios shop: Version: 2.0.2 - Released: 2019-09-30

Did you hear back from UJAM and are they able to reproduce the issue at their end?

Greg

Tweak
Posts: 78
Joined: 16 Jan 2015

Post 02 May 2020

Hey, thanks for the reply.

I never did take the opportunity to contact UJAM about this, not had much time for music making, and things recently been busy and difficult. I've tried again to see if I can make this crash, and I can, a simple 9 bar loop with some notes played via Sequences player. If I leave it to run for 10 minutes, stop it, run it again for a few minutes and then stop it and start it again.

Nothing in the rack exception Sequences and Virtual Drum Solid.

Marc

Ambis
Posts: 3
Joined: 09 May 2021

Post 28 May 2021

Does the exact same here, after 25min of looping (I timed it twice)
The individual drum samples can still be triggered, but not the drumming sequence that are built in, which is why I got it.
I have the 2.0.2 version, and I did just send Ujam a bug report.

And I tested the Heavy version too, same thing, times out after 25min on the dot.

User avatar
Ottostrom
Posts: 701
Joined: 13 May 2016

Post 29 May 2021

I have Virtual Drummer Phat and had this exact thing happen to me as well.

epoch
Posts: 62
Joined: 15 May 2021

Post 03 Jun 2021

I downloaded the VST trials for each of the Virtual Drummers, then dragged and dropped all the MIDI files to my desktop (took a little while)

Now I use those for the sequences instead of the single note triggers. This has fixed these devices ever failing on me now. I would share the MIDI files I've exported but I imagine UJAM wouldn't be impressed...

WOO
Posts: 188
Joined: 07 Aug 2019

Post 03 Jun 2021

That's funny. I was using some ujam product trials this morning and that's the same thought I had. Better get busy!
Last edited by WOO on 03 Jun 2021, edited 1 time in total.
"A man is like a rabbit, you catch him by the ears" La Rochefoucauld

WOO
Posts: 188
Joined: 07 Aug 2019

Post 03 Jun 2021

Does anyone know where ujam keeps the midi files? Using windows 10. Did a search of my system was unable to find.
"A man is like a rabbit, you catch him by the ears" La Rochefoucauld

epoch
Posts: 62
Joined: 15 May 2021

Post 04 Jun 2021

WOO wrote:
03 Jun 2021
Does anyone know where ujam keeps the midi files? Using windows 10. Did a search of my system was unable to find.
You have to drag and drop each one manually from the VST interface to your Desktop.

Have fun!

epoch
Posts: 62
Joined: 15 May 2021

Post 16 Jun 2021

WOO wrote:
03 Jun 2021
Does anyone know where ujam keeps the midi files? Using windows 10. Did a search of my system was unable to find.
I'm on Mac so used ControllerMate, but if you're on Windows there's stuff like Autohotkey.

I wrote a script to automate the dragging and dropping of the MIDI so I didn't have to sit and do it manually 1380 times for each product!

User avatar
TheGodOfRainbows
Posts: 580
Joined: 31 Mar 2015

Post 28 Jun 2021

So, I'm having this problem. And I've had it ever since I bought the Ujam Virtual Drummers. After a while of working (not long maybe 10 minutes or less), the note triggers patterns just stop playing. Deleting the device and undoing that makes them work again. This happens with all the VD, Solid, Heavy, and Phat.

I am truly sick of this bug. It's really broken. It happens constantly and consistently. The fact that this thread died and no updates have been posted isn't encouraging. I can't believe there aren't more complaints. Maybe a very small number of people own them and that's why. I've just contacted Ujam and am waiting for a response.

epoch
Posts: 62
Joined: 15 May 2021

Post 29 Jun 2021

TheGodOfRainbows wrote:
28 Jun 2021
So, I'm having this problem. And I've had it ever since I bought the Ujam Virtual Drummers. After a while of working (not long maybe 10 minutes or less), the note triggers patterns just stop playing. Deleting the device and undoing that makes them work again. This happens with all the VD, Solid, Heavy, and Phat.

I am truly sick of this bug. It's really broken. It happens constantly and consistently. The fact that this thread died and no updates have been posted isn't encouraging. I can't believe there aren't more complaints. Maybe a very small number of people own them and that's why. I've just contacted Ujam and am waiting for a response.
It took me a few hours to sort out automation which ripped the MIDI files out of the VST versions of the Drummers. Time well spent.

If you get nowhere with UJAM, send me a PM and I can share with you the ReFill I made that contains all the MIDI files.

User avatar
TheGodOfRainbows
Posts: 580
Joined: 31 Mar 2015

Post 29 Jun 2021

epoch wrote:
29 Jun 2021
TheGodOfRainbows wrote:
28 Jun 2021
So, I'm having this problem. And I've had it ever since I bought the Ujam Virtual Drummers. After a while of working (not long maybe 10 minutes or less), the note triggers patterns just stop playing. Deleting the device and undoing that makes them work again. This happens with all the VD, Solid, Heavy, and Phat.

I am truly sick of this bug. It's really broken. It happens constantly and consistently. The fact that this thread died and no updates have been posted isn't encouraging. I can't believe there aren't more complaints. Maybe a very small number of people own them and that's why. I've just contacted Ujam and am waiting for a response.
It took me a few hours to sort out automation which ripped the MIDI files out of the VST versions of the Drummers. Time well spent.

If you get nowhere with UJAM, send me a PM and I can share with you the ReFill I made that contains all the MIDI files.
That's a lot of work, and very good of you to share. I would feel morally ok with that since I consider these devices to be broken. They did respond and said they are aware of the bug, but just haven't fixed it. I suspect it will never be fixed since this bug has been around for at least about a year now that I'm aware.

epoch
Posts: 62
Joined: 15 May 2021

Post 29 Jun 2021

TheGodOfRainbows wrote:
29 Jun 2021
epoch wrote:
29 Jun 2021


It took me a few hours to sort out automation which ripped the MIDI files out of the VST versions of the Drummers. Time well spent.

If you get nowhere with UJAM, send me a PM and I can share with you the ReFill I made that contains all the MIDI files.
That's a lot of work, and very good of you to share. I would feel morally ok with that since I consider these devices to be broken. They did respond and said they are aware of the bug, but just haven't fixed it. I suspect it will never be fixed since this bug has been around for at least about a year now that I'm aware.
Given a fix isn't forthcoming from UJAM, and this is a show-stopping bug we're talking about, I feel like it's fair to share this given it fixes the problem.

I've put the ReFill on WeTransfer: https://wetransfer.com/downloads/738bc1 ... 219/a3e56d

There's a 7 day expiry on the download so grab it while you can!

User avatar
TheGodOfRainbows
Posts: 580
Joined: 31 Mar 2015

Post 29 Jun 2021

epoch wrote:
29 Jun 2021
TheGodOfRainbows wrote:
29 Jun 2021

That's a lot of work, and very good of you to share. I would feel morally ok with that since I consider these devices to be broken. They did respond and said they are aware of the bug, but just haven't fixed it. I suspect it will never be fixed since this bug has been around for at least about a year now that I'm aware.
Given a fix isn't forthcoming from UJAM, and this is a show-stopping bug we're talking about, I feel like it's fair to share this given it fixes the problem.

I've put the ReFill on WeTransfer: https://wetransfer.com/downloads/738bc1 ... 219/a3e56d

There's a 7 day expiry on the download so grab it while you can!
Thank you so much for sharing! :clap: I still hope they fix the bug. Not holding my breath. This is one of the first times I've ever regretted buying the Re version of something over the VST. It's a shame they seemingly won't fix it.

User avatar
Ottostrom
Posts: 701
Joined: 13 May 2016

Post 30 Jun 2021

epoch wrote:
29 Jun 2021
Given a fix isn't forthcoming from UJAM, and this is a show-stopping bug we're talking about, I feel like it's fair to share this given it fixes the problem.

I've put the ReFill on WeTransfer: https://wetransfer.com/downloads/738bc1 ... 219/a3e56d

There's a 7 day expiry on the download so grab it while you can!
Thank you for sharing these!
I own their product so I feel justified in downloading this.

epoch
Posts: 62
Joined: 15 May 2021

Post 30 Jun 2021

Ottostrom wrote:
30 Jun 2021
epoch wrote:
29 Jun 2021
Given a fix isn't forthcoming from UJAM, and this is a show-stopping bug we're talking about, I feel like it's fair to share this given it fixes the problem.

I've put the ReFill on WeTransfer: https://wetransfer.com/downloads/738bc1 ... 219/a3e56d

There's a 7 day expiry on the download so grab it while you can!
Thank you for sharing these!
I own their product so I feel justified in downloading this.
No problem!

I never understood why these weren't just included inside the UJAM REs themselves. It's definitely do-able as the Reason Drum Kits RE contains MIDI patterns inside it; you browse to Rack Extension > Reason Drum Kits using the Import MIDI browser, you can then drag them to the sequencer from there.

Oh well, I have found that this ReFill I made works really well for getting better results with the UJAM REs and also for avoiding the bug of the single note pattern triggers failing.

JorgeM
Posts: 8
Joined: 17 May 2021

Post 30 Jun 2021

Thanks, epoch. I've also encountered issues with a Virtual Drummer device. This is much appreciated.

Cseger1
Posts: 5
Joined: 13 Mar 2019

Post 01 Aug 2021

Popping in to say that UJAM heavy does it also. I've watched the plugin as it crashes and for me, its when certain key combos trigger simultaneously. Kick and crash specifically which ARGH! I can slide the crash off the beat and the crash won't occur.

If I had to guess, just looking at it when it crashes, I'd say it is getting midi on messages too rapidly to then receive the midi off message and it gets jammed. You old people will remember what happens on a mechanical typewriter when you hit a handful of keys at once. To my eye, this is the digital version of that.

Cseger1
Posts: 5
Joined: 13 Mar 2019

Post 01 Aug 2021

Popping in to say that UJAM heavy does it also. I've watched the plugin as it crashes and for me, its when certain key combos trigger simultaneously. Kick and crash cymbal specifically which ARGH! I can slide the cymbal off the beat and the UJAM won't crash.

If I had to guess, just looking at it when it crashes, I'd say it is getting midi on messages too rapidly to then receive the midi off message and it gets jammed. You old people will remember what happens on a mechanical typewriter when you hit a handful of keys at once. To my eye, this is the digital version of that.

WOO
Posts: 188
Joined: 07 Aug 2019

Post 04 Aug 2021

I've had the same issues with the ujam re's. Also the a list guitar and drum re's that ujam and reason worked on jointly. All would stop working at some point and i would have to drag and drop the same re onto the existing re and it would magically work again. I can live with that though. Maybe that's one of the reasons the a list re's got discontinued. Thanks for the midi files btw. Much appreciated
"A man is like a rabbit, you catch him by the ears" La Rochefoucauld

Ambis
Posts: 3
Joined: 09 May 2021

Post 23 Sep 2021

On my win10 big system, I have conducted 8 tests.

All 8 ends the same way, but conducted in different ways. Some are just played on loop until it times out (no longer triggering) or a combination of playing, pausing for short or long periods and the playing some more until it times out. Result is that after 60min or 3600 seconds, it stops triggering. Individual samples can be triggered, but its onboard triggering system is no longer working.

To me that sounds like an embedded code timer/loop that isnt reset properly.

Hirnilein0815
Posts: 2
Joined: 03 Nov 2021

Post 03 Nov 2021

Same issue with me. I bought all three Virtual Drummers some time last year, and all three of them stopped working after some minutes in use from the the first day on. I was hoping that maybe some Reason update might solve the issue, but this was not the case. It seems quite abvious to me that this is a bug Ujam has to fix.

If, for some reason, this is not possible, I would appreciate very much a "MIDI to Track" function where I can expand the drum sequences to single notes like in Dr. Octo Rex.

In the meantime, epoch, would you mind to upload your ReFill once again?

  • Information
  • Who is online

    Users browsing this forum: challism, CommonCrawl [Bot] and 3 guests