UMPF Club Drums RE

This forum is for discussing Rack Extensions. Devs are all welcome to show off their goods.
User avatar
Carly(Poohbear)
Posts: 2794
Joined: 25 Jan 2015
Location: UK

Post 16 Sep 2020

client6 wrote:
15 Sep 2020
priior wrote:
27 Jan 2019


4) Have a parallel out for each channel so we can feed it into a sidechain. (unless someone figured out an easy way to send out the kick signal without messing the internal routing?)
Has anyone figured out a workaround to sidechain with the kick's gate out or another method without breaking the routing?

Thanks!
Using the Kick's Gate out does not break any of the routing and IMO gives you more control over using audio out.

client6
Posts: 71
Joined: 10 Jun 2020

Post 17 Sep 2020

Thanks Carly. I tried the tutorial here (https://www.reasonexperts.com/the-main- ... ssion.html) and also putting the gate out to an ADSR and shaping the signal to output to a 14:2 mixer to lower the master level CV but I guess I'm not quite getting it right. Any tips?

Thanks!

User avatar
Carly(Poohbear)
Posts: 2794
Joined: 25 Jan 2015
Location: UK

Post 17 Sep 2020

client6 wrote:
17 Sep 2020
Thanks Carly. I tried the tutorial here (https://www.reasonexperts.com/the-main- ... ssion.html) and also putting the gate out to an ADSR and shaping the signal to output to a 14:2 mixer to lower the master level CV but I guess I'm not quite getting it right. Any tips?

Thanks!
Personally I would use the Janitor to shape it (even pre an envelope), using the Decay on it you can use then use the sustain from a envelope..

So here I'm using the CV1 of the Janitor to delay the CV signal, using the Env from Little LFO, the 2nd CV on the janitor is inverting the signal as well as scaling it down then I'm effect the level of the mix channel. You might get away with using the Delay only on the Janitor.
Capture.JPG
Capture.JPG
You do not have the required permissions to view the files attached to this post.

client6
Posts: 71
Joined: 10 Jun 2020

Post 18 Sep 2020

Thanks so much for the detailed explanation. I got it to work, really appreciate the pictures.

Thanks!

Steedus
Posts: 764
Joined: 31 Aug 2015
Location: Melbourne, AU

Post 07 Jun 2022

Just a heads up if anyone else comes across this:

Can't believe this never came up for me before but I've run into a bug when trying to use the direct outs on Club Drums.

In a saved patch (come to think of it, I've only tried pre-set patches that it shipped with), any channel that's using the "COMP" output bus will be silent when connecting it's direct output to something else (like a line mixer). Switching on and off the "CLEAN" bus, will make the "COMP" bus start working again.

Any channels that are using the "CLEAN" output bus work as expected.

I've reported the issue.

Eddi-16
Posts: 251
Joined: 12 Aug 2017

Post 10 Jun 2022

Yep, its definetly a bug. Tried it, same problem...

Eddi-16
Posts: 251
Joined: 12 Aug 2017

Post 12 Jun 2022

If you select & turn on "distortion" in the bitcrusher tab and turn it off, distorted sound effect stays sometimes "on" randomly - it depends on distortion type...

buggy, too.

Steedus
Posts: 764
Joined: 31 Aug 2015
Location: Melbourne, AU

Post 12 Jun 2022

Interestingly, after confirming the bug they said they’d pass it on to the dev team but “no promises” on fixing it. .. Really?

Btw, even if you “fix” it in a session, if you close it and reload the save all the COMP channels are silent again until you turn on and off CLEAN.

rootwheel
Posts: 290
Joined: 21 Aug 2021

Post 12 Jun 2022

Steedus wrote:
07 Jun 2022
Just a heads up if anyone else comes across this:

Can't believe this never came up for me before but I've run into a bug when trying to use the direct outs on Club Drums.

In a saved patch (come to think of it, I've only tried pre-set patches that it shipped with), any channel that's using the "COMP" output bus will be silent when connecting its direct output to something else (like a line mixer). Switching on and off the "CLEAN" bus, will make the "COMP" bus start working again.

Any channels that are using the "CLEAN" output bus work as expected.

I've reported the issue.
The bug is worse than this for me, it's not just COMP that's broken; it's standard setup without either COMP or CLEAN activated for its channel.

If I create a simple patch not using the COMP or the CLEAN outputs and just route each of the separate outputs to their own Line Mixer, they don't work if the cabling is done after loading the patch but they do they work if a patch is loaded after the cabling. Either way, upon saving and then reopening the song - none of the separate outputs now work. I have to reload my patch in the song or toggle the CLEAN/COMP buttons on and off to bring the separate outputs back to life.

As you said, the only way to keep separate outputs working between sessions is with the CLEAN button activated for each channel. Otherwise, they're always bust on reload of a project for me, no audio comes out of the separate outputs.

Umpf Retro Beats doesn't have this bug because it doesn't have the CLEAN/COMP bus implementation of Club Drums.
Last edited by rootwheel on 13 Jun 2022, edited 1 time in total.

Steedus
Posts: 764
Joined: 31 Aug 2015
Location: Melbourne, AU

Post 12 Jun 2022

And parts of the UI are still not HD. Sad that one of their own “sold separately” products still has issues.

User avatar
mimidancer
Posts: 206
Joined: 30 Sep 2021

Post 13 Jun 2022

client6 wrote:
15 Sep 2020
priior wrote:
27 Jan 2019


4) Have a parallel out for each channel so we can feed it into a sidechain. (unless someone figured out an easy way to send out the kick signal without messing the internal routing?)
Has anyone figured out a workaround to sidechain with the kick's gate out or another method without breaking the routing?

Thanks!
I always use a separate redrum to trigger any pumping. It has one sample loaded and is not connected to audio. Pumping the compressor is its only job.

rootwheel
Posts: 290
Joined: 21 Aug 2021

Post 13 Jun 2022

Here's the bit on separate outputs according to the manual: https://shop-20220407094725533500000002 ... Manual.pdf
Separate Outputs:

The separate outputs can be used for routing individual Drum Channels to external destinations, for further processing.

! Note that Drum Channels routed to separate outputs will be automatically disconnected from the Clean and Comp busses. Note, though, that the signal can still be sent to the Send Effects (Chop, Delay and Reverb).
I'm trying to work out if the device is actually working as intended on reload, that the Clean button is supposed to be on for a channel to work with the external outputs. Therefore the bug is actually that audio is coming out of the separate outputs to begin with without the Clean button enabled - but after a project reload it then doesn't output; as it should have behaved from the beginning.

  • Information
  • Who is online

    Users browsing this forum: CommonCrawl [Bot], Google [Bot] and 6 guests