format_version of SDK main project files?

This forum is for developers of Rack Extensions to discuss the RE SDK, share code, and offer tips to other developers.
User avatar
turn2on
RE Developer
Posts: 834
Joined: 13 Mar 2015

Post 13 Oct 2023

I look at my builds, look at current 440_235 SDK Examples.. And look to the Developer Support section of the site with descriptions, and have various versions in "format_version"..

motherboard_def.lua:
- SDK 440_235: format_version = "2.0" :?:
- My projects: format_version = "2.0"
- Dev Support: format_version = "3.0" :!:
... File format version of the motherboard_def.lua file. Should be "3.0" for this version of the SDK. Required. (description of SDK 4.4.0)

What's right to use? And what if we use 2.0 vs 3.0?


realtime_controller.lua:
- SDK 440_235: format_version = "1.0"
- My projects: format_version = "1.0"
- Dev Support: format_version = "1.0"

info.lua:
- SDK 440_235: format_version = "2.0" :?:
- My projects: format_version = "1.0"
- Dev Support: format_version = "1.0" :!:

texts.lua:
- SDK 440_235: format_version = "1.0"
- My projects: format_version = "1.0"
- Dev Support: format_version = "1.0"

display.lua:
- SDK 440_235: format_version = "1.0"
- My projects: format_version = "1.0"
- Dev Support: format_version = not find

hdgui_2D.lua
- SDK 440_235: format_version = "2.0"
- My projects: format_version = "2.0"
- Dev Support: format_version = "2.0"

device_2D.lua
- SDK 440_235: format_version = "2.0"
- My projects: format_version = "2.0"
- Dev Support: format_version = "2.0"

User avatar
turn2on
RE Developer
Posts: 834
Joined: 13 Mar 2015

Post 13 Oct 2023

Already have answer at new Dev forum:

info.lua:
Version 2.0 is required if the device type is note_player.

motherboard_def.lua:
Version 3.0 is required if your device supports pattern automation.

display.lua:
Version 1.0 is the latest and only version

  • Information
  • Who is online

    Users browsing this forum: CommonCrawl [Bot] and 0 guests