New SDK 4.3.0

This forum is for developers of Rack Extensions to discuss the RE SDK, share code, and offer tips to other developers.
User avatar
pongasoft
RE Developer
Posts: 372
Joined: 21 Apr 2016
Location: Las Vegas

Post 25 Oct 2021

Although I have yet to see any announcement it looks like the new SDK has been released: https://developer.reasonstudios.com/doc ... _sdk_4_3_0

Yan

User avatar
Loque
Moderator
Posts: 9549
Joined: 28 Dec 2015

Post 25 Oct 2021

So, finally better Hires support 👍
Reason12, Win10

User avatar
Billy+
Posts: 3191
Joined: 09 Dec 2016

Post 25 Oct 2021

What's the minimum Reason version requirements?
VST 2.4 MIDI It's definitely on the list of todos
Using Reason since version 1 is R11 going to be my final version :shock:

ˁ˚ᴥ˚ˀ Time for a good long sleep ˁ˚ᴥ˚ˀ

User avatar
littlejam
Posts: 437
Joined: 15 Jan 2015

Post 25 Oct 2021

hello,

just here to bookmark this thread
and see what types of comments are made

i hope the new sdk 4.3 will still run on reason 10

cheers and eat well

j
littlejamaicastudios
i7 2.8ghz / 24GB ddr3 / Quadro 4000 x 2 / ProFire 610
reason 10 / reaper / acidpro /akai mpk mini / korg padkontrol / axiom 25 / radium 49
'i get by with a lot of help from my friends'

User avatar
orthodox
RE Developer
Posts: 1737
Joined: 22 Jan 2015

Post 25 Oct 2021

Billy+ wrote:
25 Oct 2021
What's the minimum Reason version requirements?
https://developer.reasonstudios.com/dow ... ension-sdk:
Version 4.3.0 - Release October 25 2021
...
Rack Extension created with this SDK requires Reason 10.1 or later.

User avatar
littlejam
Posts: 437
Joined: 15 Jan 2015

Post 25 Oct 2021

hello,

thanks for the confirmation

cheers and eat well
(cuban sandwiches)

j
littlejamaicastudios
i7 2.8ghz / 24GB ddr3 / Quadro 4000 x 2 / ProFire 610
reason 10 / reaper / acidpro /akai mpk mini / korg padkontrol / axiom 25 / radium 49
'i get by with a lot of help from my friends'

FrankyCHAMBERS
Posts: 7
Joined: 19 Aug 2021

Post 03 Nov 2021

How do you generate rack extension with Hi-Res graphic ?
I have installed SDK4.3.0 and compile my 45 but it's still in low res in Recon
R2DRender.exe log informs tthat it is "Processing GUI at 1/5 scale..."
But I notice the beta I submited to Reason is in Hi-Res.

User avatar
buddard
RE Developer
Posts: 1022
Joined: 17 Jan 2015
Location: Stockholm

Post 03 Nov 2021

FrankyCHAMBERS wrote:
03 Nov 2021
How do you generate rack extension with Hi-Res graphic ?
I have installed SDK4.3.0 and compile my 45 but it's still in low res in Recon
R2DRender.exe log informs tthat it is "Processing GUI at 1/5 scale..."
But I notice the beta I submited to Reason is in Hi-Res.
Add the hi-res command line option after the destination directory:

Code: Select all

RE2DRender GUI2D/ GUI/ hi-res

FrankyCHAMBERS
Posts: 7
Joined: 19 Aug 2021

Post 03 Nov 2021

Thanks !

I tried /help --help /? before asking... and finally ask the forum !

  • Information
  • Who is online

    Users browsing this forum: CommonCrawl [Bot] and 0 guests