Optimize for bx_Oberhausen etc.?

Discuss VST stuff here!
User avatar
Mistro17
Posts: 164
Joined: 04 Jul 2017
Location: Brooklyn, NY

Post 04 Jan 2021

Using bx_Oberhausen as a case study example to figure out why certain instruments do not play nice on my end. As soon as I open this plugin, I see my DSP meter go up without even touching anything. Anyone here using it with no problems in Reason and what are your settings? I tried some audio tweaking but I can't figure out how to optimize to get this thing to play clean. At the moment I have my audio settings shown in the image. My system sound is at 16bit, 44100.
Audio_1.png
You do not have the required permissions to view the files attached to this post.

PhillipOrdonez
Posts: 1605
Joined: 20 Oct 2017
Location: Colombia

Post 04 Jan 2021

Try increasing the buffer size? My guess is your processor isn't that new? Also, asio4all? Doesn't your sound interface have proprietary drivers? Unless you don't have a sound interface and are using the built in one? 😱

User avatar
Mistro17
Posts: 164
Joined: 04 Jul 2017
Location: Brooklyn, NY

Post 04 Jan 2021

PhillipOrdonez wrote:
04 Jan 2021
Try increasing the buffer size? My guess is your processor isn't that new? Also, asio4all? Doesn't your sound interface have proprietary drivers? Unless you don't have a sound interface and are using the built in one? 😱
My processor is a i7-8700k and my audio interface is a Behringer U-Phoria UMC22. I tried both asio4all and the the default driver for my interface. Everything is running on a M.2 1T ssd card.

Threpus
Posts: 13
Joined: 24 Dec 2018

Post 04 Jan 2021

I bought that synth recently, and it can be a bit of a hog- but an 8700k should be able to handle multiple instances. In my experience, Reason doesn't do well with hyperthreading. Keep the multicore box checked, but uncheck hyperthreading.

tanni
Posts: 135
Joined: 19 Jul 2015

Post 04 Jan 2021

Threpus wrote:
04 Jan 2021
.... In my experience, Reason doesn't do well with hyperthreading. Keep the multicore box checked, but uncheck hyperthreading.
yes, thats exacly my experience too with u-he synths like Diva and Repro 5. They perform much better without Hyperthreading in Reason.

User avatar
zoidkirb
Posts: 452
Joined: 18 Nov 2018
Location: Brisbane Australia

Post 04 Jan 2021

Running an AMD 3600 (slightly weaker that your CPU) with a first gen Scarlet at 48k and 128 buffer I can load 8 Oberhausens at once all with a 16 voice unison and TMT turned on. One bar of DSP at idle which goes up to 4 bars once I play a chord.
I've got all the same boxes as you checked in Preferences too.
Your rig should do a lot better, so It's very possible it's a driver issue. Try 48k too. Shouldn't be an issue really, but you never know.

Edit: It seems to be the number of unison voices that really chew through CPU. Once I get up to 32 things get flakey, fast.

Mataya
Posts: 129
Joined: 03 May 2019

Post 04 Jan 2021

Don't know about Oberhausen, but I tried setting my minimum processor state to 100% and it drastically improved my cpu consumption with softube modular vst, because it was giving me headaches since I bough it.
But, you have to be careful and check some stuff. For example, I tried this before when I had old windows 10 installed. I've updated my win10 few months ago and tried it again.
Now it works like this...wen I set minimum processor state to 100, my vst perform better and when I check my processor usage when no programs are running, processor looks like it's not doing anything, idle.
Before on my old windos 10, when I did the sam thing, my processor was showing 100% usage, the ventilators were running full speed even when no programs were running. So I avoided that setting before.
Now it seems like it's working when it's supposed to and softube modular performs much better. You have to go to power options, under advanced options to find those settings. minimum and maximum processor state are now at 100% on my system and it works.
So maybe you should try it, just be careful. I n Reason, I definitely get better performance when I uncheck hyper threading audio rendering and leave the other two checked.

M

danc
Posts: 590
Joined: 14 Oct 2016

Post 04 Jan 2021

Optimising one's computer for DAW use is a standard problem and not related to Oberhausen in particular. It's been discussed here on ReasonTalk a few times - do a search and you'll find them.

However.. looking further afield... there are a number of sites that help with this - one which I personally found useful was on the Focusrite website and it isn't intended just for Focusrite user's - it can be for any audio card setup you have:

https://support.focusrite.com/hc/en-gb/ ... timisation

Listed on that page are solutions for PC and Mac. On the PC page - scroll down to the MAIN TIPS as it has some really helpful things to consider.

As an example - I noticed that OneDrive was frequently taking up a high amount of CPU just for its backgound scanning sequence that it does. I nailed that on the head by unlinking my OneDrive and re-linking it - which cleared everything up and it now doesn't hog my PC. Now my PC is super smooth and my DAWs have so much more bandwidth to play with.
300+ original grooving Techno, Tech-House, House, Drum-and-Bass tracks on SoundCloud.
Produced in Reason 11 and Studio One 5 (WIndows).


PhillipOrdonez
Posts: 1605
Joined: 20 Oct 2017
Location: Colombia

Post 04 Jan 2021

Given your specs, I'd go with optimizing the machine as danc suggests. In addition to that, if it is a laptop, don't work unless plugged in, and only use the proprietary drivers.

And yes, hyperthreading ticked off can result in better performance sometimes. Try that too.

User avatar
Mistro17
Posts: 164
Joined: 04 Jul 2017
Location: Brooklyn, NY

Post 04 Jan 2021

Thanks a lot for the replies and help! Turning off hyper-threading and using the default audio interface driver seem to work so far. The default driver for the audio interface I think made a world of difference. I was mistaking it for another one that starts with ASIO followed by my interface name. I hit some chords hard as a stress test and no more popping and crackling. Feels good to finally play with bx (sounds awesome). I even got Analog Dreams to play nice finally. I will play for a while and see if the issue comes back.
Audio_2.png
You do not have the required permissions to view the files attached to this post.

User avatar
aeox
Posts: 2814
Joined: 23 Feb 2017

Post 04 Jan 2021

Mistro17 wrote:
04 Jan 2021
PhillipOrdonez wrote:
04 Jan 2021
Try increasing the buffer size? My guess is your processor isn't that new? Also, asio4all? Doesn't your sound interface have proprietary drivers? Unless you don't have a sound interface and are using the built in one? 😱
My processor is a i7-8700k and my audio interface is a Behringer U-Phoria UMC22. I tried both asio4all and the the default driver for my interface. Everything is running on a M.2 1T ssd card.
Turn off Hyper threading in the Reason preferences.

This has always made huge improvements for me but I'm curious to know if it helps you.

edit: Just read the other posts, oops :D

User avatar
TheDragonborg
Posts: 266
Joined: 10 Feb 2020

Post 04 Jan 2021

I dunno since this plugin doesn't even make a dent on my DSP meter...

And yeah turning off hyperthreading would do nothing since that's for audio export and in fact turning that off would make things worse on systems that support it (Intel CPUs). It would just make it take longer to export audio.

  • Information
  • Who is online

    Users browsing this forum: CommonCrawl [Bot] and 0 guests