The Latest Update of Omnisphere Does Not Fix the Reason Crashing Thing

Discuss VST stuff here!
User avatar
hurricane
Posts: 1494
Joined: 14 Oct 2017

Post 04 Jun 2020

YAY.

Release notes:

Omnisphere Software 2.6.3c (Version History)
Includes the following features and fixes:

Fixes issues with host automation parameters in Logic Pro 10.5
Fixes bug where existing automation assignments were deleted after Unlearning an automation assignment
Fixes bug where new automation IDs were incorrectly assigned after Unlearning an automation assignment
Fixes intermittent crash when opening saved Logic Pro X projects on macOS 10.15
Fixes issue where Omnisphere could freeze Live 10.1 on macOS 10.15
Fixes crash when deleting a track containing Omnisphere in Reason
Improved Authorization process and GUI layout
Last edited by hurricane on 06 Jun 2020, edited 1 time in total.
https://soundcloud.com/hurricane-music | https://soundcloud.com/hurricaneaudiolab
Mac mini | Logic Pro X | Reason 10.4 | DX7 | DX7s | TX7 | CZ-1 | JP-8080 | Virus Classic | Roland XP-80/XP-30/RD-700/D2/TR-09 | microKorg I 03R/W | SL990 PRO

User avatar
VIVIsect
Posts: 129
Joined: 28 May 2017

Post 04 Jun 2020

I updated and it's still crashing for me. Same as before, with the "read problem" message.

User avatar
hurricane
Posts: 1494
Joined: 14 Oct 2017

Post 04 Jun 2020

Dangit - yes, it still crashes. How did they miss this with James Bernard working there?

I sent in a ticket.
https://soundcloud.com/hurricane-music | https://soundcloud.com/hurricaneaudiolab
Mac mini | Logic Pro X | Reason 10.4 | DX7 | DX7s | TX7 | CZ-1 | JP-8080 | Virus Classic | Roland XP-80/XP-30/RD-700/D2/TR-09 | microKorg I 03R/W | SL990 PRO

Michaellos
Posts: 107
Joined: 18 May 2016

Post 04 Jun 2020

VIVIsect wrote:
04 Jun 2020
I updated and it's still crashing for me. Same as before, with the "read problem" message.
Yes, exactly the same, nothing changed ... very annoying

bigguy1
Posts: 77
Joined: 28 Sep 2018

Post 05 Jun 2020

For me it is working. When deleting there is no crash anymore. I'm on Reason 11 Suite.

User avatar
hurricane
Posts: 1494
Joined: 14 Oct 2017

Post 05 Jun 2020

bigguy1 wrote:
05 Jun 2020
For me it is working. When deleting there is no crash anymore. I'm on Reason 11 Suite.
Did you open Omnisphere and let the default preset load first? It crashes when you delete it AFTER you open Omnisphere.
https://soundcloud.com/hurricane-music | https://soundcloud.com/hurricaneaudiolab
Mac mini | Logic Pro X | Reason 10.4 | DX7 | DX7s | TX7 | CZ-1 | JP-8080 | Virus Classic | Roland XP-80/XP-30/RD-700/D2/TR-09 | microKorg I 03R/W | SL990 PRO

bigguy1
Posts: 77
Joined: 28 Sep 2018

Post 05 Jun 2020

hurricane wrote:
05 Jun 2020
bigguy1 wrote:
05 Jun 2020
For me it is working. When deleting there is no crash anymore. I'm on Reason 11 Suite.
Did you open Omnisphere and let the default preset load first? It crashes when you delete it AFTER you open Omnisphere.
Either way, there is no crash on my system. I tried to
  • create Omnisphere and delete it without playing it (not opened the GUI)
  • create Omnisphere and delete it without playing it (opened the GUI in the splash screen with the Update check)
  • create Omnisphere and delete it with playing the default patch
  • create Omnisphere and delete it with changing the preset
No crash at all. Works fine for me. Btw I am on Windows 10.

User avatar
hurricane
Posts: 1494
Joined: 14 Oct 2017

Post 05 Jun 2020

Thanks - yeah, I'm on Mac. Crashes for me still.
https://soundcloud.com/hurricane-music | https://soundcloud.com/hurricaneaudiolab
Mac mini | Logic Pro X | Reason 10.4 | DX7 | DX7s | TX7 | CZ-1 | JP-8080 | Virus Classic | Roland XP-80/XP-30/RD-700/D2/TR-09 | microKorg I 03R/W | SL990 PRO

bigguy1
Posts: 77
Joined: 28 Sep 2018

Post 05 Jun 2020

That's unfortunate. At least Reason does not crash and you just have to delete twice :D

User avatar
VIVIsect
Posts: 129
Joined: 28 May 2017

Post 05 Jun 2020

I'm on Win 10/Reason 11 Suite as well, and it still crashes every time for me. Weird. Dunno what differences there could be. I also have the Moog Tribute library installed, but doubt that's causing any trouble.

Gosh
Posts: 29
Joined: 16 Jul 2015

Post 13 Jun 2020

still crahes here, too. windows 10

User avatar
wendylou
Posts: 275
Joined: 15 Jan 2015
Location: Saint Joseph, MO

Post 03 Oct 2020

Is Omnisphere usable inside Reason Suite 11, or do these crashes render it unusable in Reason?
:PUF_balance: http://www.galxygirl.com -- :reason: user since 2002

User avatar
VIVIsect
Posts: 129
Joined: 28 May 2017

Post 03 Oct 2020

wendylou wrote:
03 Oct 2020
Is Omnisphere usable inside Reason Suite 11, or do these crashes render it unusable in Reason?
It works fine. It's only when you try to delete an instance of Omnisphere you'll get the error. You can dismiss the error and the second time you can successfully delete it. It doesn't crash Reason or anything. Omnisphere is my most used synth, and I haven't found to be that big of a deal. Just a slight annoyance.

User avatar
wendylou
Posts: 275
Joined: 15 Jan 2015
Location: Saint Joseph, MO

Post 04 Oct 2020

Thanks. So I proceeded to purchase last night! I have high speed internet but their servers drizzled that 60GB download. I woke up this morning and installed.

I've been lost in exploration of the sounds all day! The massive sound collection is impressive! I've already used a few choice patches. Lot's of inspiration in there. I'm extremely happy with this addition to my Reason Suite rack. Very addictive, but I gotta take a break though before my brain melts!

Some patches are too hot and crackle, as noted by other reviewers, but it's easy to remedy with the Omnisphere gain and level controls. I've noted similar issues with Pigments 2 on certain patches. And #metoo on the VST error when deleting – I have to double delete if removing it from the rack. No biggie. Reasons still runs fine.
:PUF_balance: http://www.galxygirl.com -- :reason: user since 2002

groggy1
Posts: 434
Joined: 10 Jun 2015

Post 15 Nov 2020

Exciting news folks!!

Omnisphere 2.6.4c seems to FIX the crash-on-delete bug in Reason!

WOOHOOO!!!!!


Here's a summary of the bug that is now fixed:
1) Insert Omnisphere
2) Open the GUI and select a sound
3) Close GUI
4) Delete the Omnisphere instance in the rack
---> This would lead to Reason giving an error message that Omnisphere had crashed, but you could dismiss it, and then a SECOND delete of Omnisphere would remove it from the rack

This wasn't blocking, but it was super-annoying. And now seems fixed!

[edited to clarify bug details]

  • Information
  • Who is online

    Users browsing this forum: CommonCrawl [Bot], Creativemind and 4 guests