reason does norecognize Slate Drums (fixed)

Discuss VST stuff here!
User avatar
bama
Posts: 18
Joined: 29 May 2015

Post 09 Apr 2020

Hi,

I've been using SSD 5.0 since VSTs can be used in Reason, I'm on 11 now.
A few weeks ago, SSD 5.5 came along, which I installed without any prior research into problems, because Slate never gave me any problems. Well turns out, it crashes Reason. At least for me on my Macbook Pro, running Mojave.
No Problem, would've been nice, but not terribly important, as it only has a few new features I'd likely use.
I trashed the 5.5 sampler an reinstalled the 5.0 version.
Now Reason gives me the "could not load'- message in the plug-in manager and also doesn't recognize the developer, or what kind of a plug-in it is.
Protools and Studio One 4 recognize it just fine, and Ioad it without any problems.This is the same Sampler Version (5.0), I've been using since it came out.
Does this behavior sound familiar to any of you? If yes, I'd appreciate any helpful information. Thanks!!

Upgrade to 11.3 fixed it. Sorta.
All of a sudden 5.0 Sampler which could not be loaded, and did not show as "instrument" suddenly is shown as just that and can be loaded and used. Same with 5.5. , which does not crash Reason any more. So far so good.
I can no longer use my saved Drumsets any more, which is ok, I can recreate them, creating new ones works. Whatever.
Keep in mind, during all of this, Slate Drums 5.0 and 5.5 worked flawlessly in ProTools 11 and Studio One 4 Pro.

So the good thing about this is that I´ve spent quite a bit of time in Studio One, getting to know the programm better, even thinking of using Reason only for electronic stuff, as originally intended. As I've gotten quite attached to some of my RE's though, I think I'll be going back.

  • Information
  • Who is online

    Users browsing this forum: boggg1, CommonCrawl [Bot] and 1 guest