Omnisphere 2.6 Crashing

Discuss VST stuff here!
User avatar
NekujaK
Posts: 612
Joined: 09 Oct 2016
Location: USA

Post 10 Apr 2019

The latest Omnisphere update works fine in Reason... until I try to delete an instance from the rack. Then two error messages appear - the first is Reason's standard VST plugin crash message, followed by a message saying there's some kind of "read error".

Is anyone else experiencing this?

There are a handful of VSTs that crash when deleting them from the rack, I hope Omnisphere isn't joining their ranks :(
wreaking havoc with :reason: since 2.5

User avatar
WillyOD
Posts: 239
Joined: 20 Jan 2015
Location: Left of stardust

Post 10 Apr 2019

There's a ticket in the (Reason) beta, apparently it's caused by Omnisphere 2.6 and it's not working at the moment even in the beta.

Solution? Never delete it ;D
I've never seen so many colours... http://www.diippii.com.

User avatar
BananaSkins
Posts: 256
Joined: 29 Sep 2017

Post 10 Apr 2019

NekujaK wrote:
10 Apr 2019
The latest Omnisphere update works fine in Reason... until I try to delete an instance from the rack. Then two error messages appear - the first is Reason's standard VST plugin crash message, followed by a message saying there's some kind of "read error".

Is anyone else experiencing this?

There are a handful of VSTs that crash when deleting them from the rack, I hope Omnisphere isn't joining their ranks :(
Just a thought; why don't you try cut instead of delete?

groggy1
Posts: 338
Joined: 10 Jun 2015

Post 22 Apr 2019

This crash is still happening, so just want to see if others can confirm the behavior I'm seeing.

Setup: Windows PC with Reason 10.3 + Omnisphere 2.6

NOTE: This crash did NOT happen with Omnisphere 2.5. Only started happening with 2.6


Repro steps:
1) Add a new instance of Omnisphere 2.6 to the Reason rack
2) Open the Omnisphere VST GUI
3) Close the Omnisphere GUI by pressing the "X" in the upper-right-hand-corner of the VST window
4) Right-click on the Omnisphere wrapper in the Reason rack, and select "Delete Devices and Tracks"
Expect: Omnisphere is properly deleted
ACTUAL: Get a Reason error-message: "VST Plugin Crash: The plugin in the device "Omnisphere 1" crashed...<snip>


Note that if I NEVER OPEN the Omnisphere VST GUI, and just delete the Omnisphere wrapper in the Reason rack after step #1 above, NO CRASH.

Note that if I do the repro steps above, but skip step #3 (i.e. leave the Omnisphere GUI open while deleting the VST wrapper in the Reason rack, NO CRASH.


So net-net, it seems that the crash is somehow related to opening the Omnisphere GUI, *closing it*, and then later trying to delete the Reason VST Wrapper for Omnisphere. Didn't happen with Omnisphere 2.5.


100% repro for me. I'm curious who else reproes above, and who doesn't see it?

User avatar
boggg1
Posts: 35
Joined: 11 Jul 2015
Location: England

Post 22 Apr 2019

Same for me, Windows 10 laptop.

Tried interrogating Windows Event viewer without luck, nothing traceable reported.
Interestingly if you delete Omnisphere a second time IT seems to disappear without a problem, although this is just a work around and there may be other problems I don't know about. Nothing so far though.

CUT makes no difference, same effect.
:reason: :record: :refill: :re: :ignition: :PUF_balance: :refillpacker: :rt:

User avatar
KarmaFunkarma
Posts: 26
Joined: 20 Jul 2018

Post 22 Apr 2019

Same on MacOS 10.13.6

User avatar
hurricane
Posts: 942
Joined: 14 Oct 2017

Post 22 Apr 2019

Yup, happens on my system too.
https://soundcloud.com/hurricane-music
Mac mini (Late 2012) | Logic Pro X | Reason 10.4 | DX7 | DX7s | TX7 | CZ-1 | JP-8080 | Virus Classic | Roland XP-80/XP-30/RD-700 | Steinberg UR22mkII | Emagic AMT8 | Mackie SR24x4 | StudioLogic SL990 PRO

groggy1
Posts: 338
Joined: 10 Jun 2015

Post 22 Apr 2019

Thank you to the folks that confirmed they’re hitting this issue. If anyone else hitting it, please reply so I can send the #s to Soectrasonics in my support ticket to them.

Also, if anyone with omnisphere 2.6 does NOT hit this, that would be useful info too.

DavyB
Posts: 1
Joined: 30 Apr 2019

Post 30 Apr 2019

I can confirm this issue -

I'm running Omnisphere 2.6 and Reason 10.3 on Windows 8.

Closing the Omnisphere GUI after opening the vst crashes Reason

Only happened after I ran the 10.3 upgrade.

I also ran into a problem running the Ultranova editor vst which also causes Reason to crash after 10.3 upgrade.

Both were working fine in 10.2.

User avatar
PeZiK
Posts: 26
Joined: 18 Jan 2015
Location: Iceland

Post 30 Apr 2019

Out of curiosity, can you hardware synth control the Omnisphere software synths inside Reason? I have a lot of hardware synths that is supported by Omnisphere but not willing to spend this kind of money if the crippled Reason MIDI is not making any connection between software and hardware. Anyone?

Michaellos
Posts: 85
Joined: 18 May 2016

Post 07 May 2019

DavyB wrote:
30 Apr 2019
I can confirm this issue -

I'm running Omnisphere 2.6 and Reason 10.3 on Windows 8.

Closing the Omnisphere GUI after opening the vst crashes Reason

Only happened after I ran the 10.3 upgrade.

Exactly the same on Windows 7. Omnisphere 2.6 crashes Reason 10.3 periodically

User avatar
TAZ
Posts: 2
Joined: 27 Apr 2019
Location: Los Angeles, CA

Post 28 May 2019

Same crash and error on my 2017 Macbook Pro running Reason 10.4d4 on Mojave 10.14.5. So frustrating. On the bright side, I found this thread! So, now I know I don't have to keep banging my head against a wall trying to fix it.

VIVIsect
Posts: 42
Joined: 28 May 2017

Post 17 Aug 2019

Found this thread after experiencing the same issue. Windows 10, latest versions of Reason/Omnisphere. It doesn't crash Reason itself, only the plugin (for me at least), and after getting the error I'm then able to delete Omnisphere with no problem. Still really annoying. No issues at all with Omnisphere in Ableton Live.

Image

  • Information
  • Who is online

    Users browsing this forum: CommonCrawl [Bot] and 2 guests