Problem with Reaktor, TRK-01 (and solution)

Discuss VST stuff here!
User avatar
platzangst
Posts: 529
Joined: 16 Jan 2015

Post 01 Dec 2018

I came across an interesting problem, and managed to fix it, but for a while it was confusing and frustrating. Since part of it had to do with how Reason handles things, I figure there's a chance it might come in handy to one of you someday. So here's the long detective story.

So I've had Reaktor for a while, and a clutch of other Native Instruments things, though since Reason started I hadn't really used it directly in Reason for much of anything. But for Black Friday, I bought TRK-01 for half price, which I'd demoed before, and thought I'd see how it worked out in the rack. Well, TRK-01 is one of NI's "needs to run in Reaktor" synths, just as a number of their other devices need Kontakt. So I started Reason, put an instance of Reaktor in the rack - no problem so far - and then tried to load the TRK-01 ensemble.

An error message appeared - "problem reading trk-01.ens". Well, that's strange. I had run the demo in standalone mode just fine months ago, couldn't figure out why it wasn't working here and now. Manually, I located the place where the demo copy had been installed and tried to load that - also no go. I loaded a different ensemble - Skanner XT - and that worked just fine.

I quit Reason and then ran Reaktor by itself. TRK-01 loaded up without a problem. I was beginning to think there was something about TRK-01 that was completely incompatible with Reason somehow, but that didn't quite make sense - as long as Reaktor itself worked in Reason, it shouldn't matter what the ensembles do. But you never know these days.

Google and a search of this forum didn't show anybody else having a problem with TRK-01 or Reaktor in Reason, at least not like mine, so I was feeling stumped - until I stumbled across half an entry on the NI forums where someone else was complaining about not being able to load TRK-01 inside Maschine. The NI staff had answered, with a preliminary inquiry, and although the person never replied, it was at least a clue.

What NI had wanted the guy to do was check which version of Reaktor was running in Maschine. So I opened Reaktor and in standalone mode, checked its version - 6.2.2. Okay. Then I opened Reason up, put Reaktor in the rack, and checked its version again - 6.0.1.

Now that was interesting. For some reason, Reason was loading an older version of Reaktor. That could account for why it wasn't loading the TRK-01 ensemble, which might need the latest Reaktor updates to work. But why load old files?

Well, one thing that's happened between me getting Reaktor and me getting TRK-01, aside from Reason becoming able to use VSTs, was Native Instruments pushing its Native Access app onto me. Everyone and their pet moose these days is trying to get you to use their plug-in managing app, and NI is no exception. The thing is, when I was installing NI VSTs myself, I was directing them to install into specific directories so I could actually find them later, and to make them easier for apps to find in the Windows labyrinth; Native Access installs things wherever it decides is best and you just have to shut up and take it. This meant that when Access wanted to update Reaktor, instead of actually updating the .dll where it actually was, it just installed a whole new instance of Reaktor where it felt like doing.

Now, I'd already had Reason looking out for VSTs in NI's own favorite spot (after having to hunt down the location of some FX units I'd gotten from NI earlier), so although Reason knew where the newer installation of Reaktor was, it just wasn't loading it.

And this is where the Reason-specific part of this comes in: I don't know why, possibly because Reason scans the generic VST folder first before scanning the NI-specific folder, but in any case Reason was prioritizing the older Reaktor .dll and ignoring the more current one. It makes some sense that Reason might just not track multiple versions of the same plug-in, but it's interesting that there seems to be no checking of version numbers or which is a more recent installation to choose which to use.

But if you've read this far, you can probably guess the solution: I just deleted the old Reaktor file, and restarted Reason to get a re-scan of everything. Loaded Reaktor in the rack, and then loaded the TRK-01 ensemble - boom, there it was. Problem solved. And now, if anyone is having a similar specific issue like mine, maybe that will help you work it out. Or maybe it's just another example of how trends in software distribution are introducing issues that maybe didn't need to be introduced... isn't that right, Native Access?

  • Information
  • Who is online

    Users browsing this forum: CommonCrawl [Bot], mjxl and 0 guests