AiR Music Tech plugins freezing sessions

Reason 9.5 Bug/Issue forum
Post Reply
TopStory
Posts: 5
Joined: 24 Oct 2017

24 Oct 2017

Hey everyone, first post here but i couldnt find anything relating to my issue and im hoping someone can help.

Ive been having trouble with AiR music plugins, particularly Velvet, and it happens every single time i use it in a project. I can open it a couple of times, depending on how long its been since it was opened last and up to 3 times if i open it within seconds of closing it. It didnt start until about a month ago and its even affected past projects. After full re-installations of reason and culprits, nothing has affected the rate to which it happens, nor the frequency of freezes/crashes.

Ableton lite v9 hasnt crashed/froze once with the old or fresh install so it has to be reason right?

User avatar
Carly(Poohbear)
Posts: 1712
Joined: 25 Jan 2015
Location: UK

25 Oct 2017

There is an Xpand2 thread, where people have seen issues, I know that a number of people including my self have raised a bug with PH.

This thread starts of about the free device but read it backwards (if you want) you will see the issues.
viewtopic.php?f=48&t=7503611

TopStory
Posts: 5
Joined: 24 Oct 2017

25 Oct 2017

Thanks for the help.

There was only 1 guy I saw that said he had the same issues, as I'm not sure was an assertion error looks like pertaining to reason. I can produce it without fail, using only air plug-ins in the rack and a blank project. If I could point at a change that lines up with the time period I started experiencing this problem, it would have to be the 9.5.2 update, but I took a few months off of producing just before, so I can't be certain. It's seems to happen every time I open the plug-in window from the rack, to pick out sounds or edit them, and it freezes with no error message after the windows error reporting window shows up. It's anyways air plug-ins and never anything else.

User avatar
Carly(Poohbear)
Posts: 1712
Joined: 25 Jan 2015
Location: UK

26 Oct 2017

Note: A few of the people including my self were running Beta 10 and maybe that just handled ( in a loose term, ) the error rather than freezing.

I'm back on 9.5.2, lets see what happens over the next days.

User avatar
miscend
Posts: 688
Joined: 09 Feb 2015

26 Oct 2017

I get no errors using Xpand2. I don’t own any of the others though.

TopStory
Posts: 5
Joined: 24 Oct 2017

28 Oct 2017

I'm hoping the update will clear this up. Thanks for the help all, I won't be able to get the update till next month but I'll be back here if nothing improves.

nbot
Posts: 23
Joined: 27 Sep 2017

11 Nov 2017

Still broken in Reason 10. After several open/close GUI operations the DAW freezes

nbot
Posts: 23
Joined: 27 Sep 2017

11 Nov 2017

Btw. - I just found a workaround if you have JBridge -> create 64 to 64 bridge... - that seems to be working fine. Needless to say it's annoying. Can you guys @ Props fix it please? @MattiasHG

TopStory
Posts: 5
Joined: 24 Oct 2017

11 Nov 2017

Same here, still crashing after upgrading but I do have jbridge and ill give it a shot. Ive reinstalled everything from reason to ilok and nothing does it. AiR and Propellerhead both say its not something people are reporting but ive seen this problem show up in multiple forum sites including AiRs.

nbot
Posts: 23
Joined: 27 Sep 2017

11 Nov 2017

I already submitted a bug report to PH. This is definitely an UI issue and technically it seems not a crash but rather some infinite loop happening when refershing view in UI event loop with AIR plugins. The most performant settings with AIR plugs for JBridge for me were:
- Performance mode - on
- Run in existing auxhost - on
- Use separate GUI - on (needed because UI is not refreshed properly)
- CRASH_DETECTION 0 - defined in C:\Users\[user]\Documents\jBridge\SettingsFilesFor64BitPlugins not in UI. This seems to give slight performance boost

TopStory
Posts: 5
Joined: 24 Oct 2017

12 Nov 2017

The JBridger trick works, thanks for the suggestion.

nbot
Posts: 23
Joined: 27 Sep 2017

12 Nov 2017

TopStory wrote:
12 Nov 2017
The JBridger trick works, thanks for the suggestion.
No problem :thumbs_up:

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 18 guests