RSN 11 combi in RSN 12 and back. And Mimic un-compatibility.

This forum is for discussing Reason. Questions, answers, ideas, and opinions... all apply.
User avatar
Re8et
Posts: 1339
Joined: 14 Nov 2016

Post 07 Aug 2022

I have opened a RSN 11 combinator in RSN 12. It loaded with no problems.
I can use it, saves it, and re-open it in RSN 11 If I want.
Why can't I choose to create or use a Combinator 1.0 in RSN 12???
If it's possible to open it, then why can't we create it???

In many cases I would like to keep working with CMB 1.0 even if I use RSN 12....
I also wonder why can't I use Mimic in RSN11 if I got it in 12... What prevents me
to use it in 11??? Only HI 0Re graphics
??

User avatar
Billy+
Posts: 3994
Joined: 09 Dec 2016

Post 07 Aug 2022

Mimic is an internal device that is included with R12, it's not built using the RE SDK so it can't be used in earlier versions.

CMBv2 is the same and uses a different naming method for the internals so also isn't compatible with earlier versions even if the patches are only using the standard 4 buttons and 4 knobs.

But I'm sure you already knew that ;)
Remember this - freedom of expression does not exist in this dojo.

User avatar
Re8et
Posts: 1339
Joined: 14 Nov 2016

Post 07 Aug 2022

Billy+ wrote:
07 Aug 2022
Mimic is an internal device that is included with R12, it's not built using the RE SDK so it can't be used in earlier versions.

CMBv2 is the same and uses a different naming method for the internals so also isn't compatible with earlier versions even if the patches are only using the standard 4 buttons and 4 knobs.

But I'm sure you already knew that ;)
It seems like the cmb 1.0 once imported in RSN 12 becomes automatically 2.0...
Well I'm learning with experience... :D

User avatar
avasopht
Posts: 3451
Joined: 16 Jan 2015

Post 07 Aug 2022

Billy+ wrote:
07 Aug 2022
Mimic is an internal device that is included with R12, it's not built using the RE SDK so it can't be used in earlier versions.

CMBv2 is the same and uses a different naming method for the internals so also isn't compatible with earlier versions even if the patches are only using the standard 4 buttons and 4 knobs.

But I'm sure you already knew that ;)
AFAIK Mimic was built with the RE SDK, which is why it doesn't yet support REX import.
rootwheel wrote:
13 Sep 2021
Anyway, I've since had a reply back from Reason Studios explaining their rationale for Mimic being included in Reason 12 only and not being made available as a standalone RE in the shop as well. It turns out that a new RE SDK is in the works, supporting REX samples amongst other additions, and Mimic will be upgraded to support this in due course. As such, it made no sense releasing it standalone to begin with (despite its current compatibility with Reason 11) as I guess pretty soon the RE code itself won't be compatible with anything other than R12, as rack devices built with the new SDK will only work in Reason 12.
---

  • Information
  • Who is online

    Users browsing this forum: CommonCrawl [Bot] and 4 guests