Keep losing my Balance!

This forum is for discussing Propellerhead's music software. Questions, answers, ideas, and opinions... all apply.
Post Reply
shropshirelad
Posts: 44
Joined: 24 Jun 2015

17 Jul 2017

My PH Balance interface keeps disconnecting itself. Sometimes it will re-appear without me doing anything. At other times if I unplug/plug back in the midi cable it will reappear. At all times it's become an unreliable pain in the bottom!

Is anyone else experiencing this? Is there a solution other that biting the bullet and sending it to Room 101? I haven't been able to track down anything that may be causing the issues - it appears to have a mind of its own!

I use an iMac running OS 10.12.1.

Cheers for any help.

Palmeira
Posts: 90
Joined: 18 Jan 2015

17 Jul 2017

I'm on Win 10 and my Balance needs disconnecting and reconnecting again at least once a session but then that is an unsupported version of Windows and the Balance is getting on a bit now to be fair. Have you tried another USB cable?

The_Grass
Posts: 6
Joined: 04 Sep 2016

18 Jul 2017

Go back tot Windows 8.1

User avatar
AttenuationHz
Posts: 859
Joined: 20 Mar 2015
Location: Back of the Rack

18 Jul 2017

This keeps happening to my midi keyboard I have very annoying. It was right after I used EMI to route a matrix to a hardware synth too using the keyboard as the go between.
Waiting for Navigation by Routing to be added! viewtopic.php?f=6&t=7496036&p=275497#p275497

Ostermilk
Posts: 1215
Joined: 15 Jan 2015
Contact:

19 Jul 2017

Sometimes disallowing the USB hub/port from going into hibernation can solve this issue. It's not just a Balance problem any USB interface can suffer from it. It happens when the port wakes up again and it doesn't re-initialize the interface and sometimes you can lose communication with it. This is why it can be solved sometimes by unplugging the interface and plugging it back in again.

I'm not sure how you'd prevent the USB ports from sleeping on a Mac but on Windows you can either set it in the Power Plan advanced settings or by using device manager and selecting properties on either the USB port/hub is is connected to or the device itself choosing the Power Management tab and unchecking the Allow Computer to turn off the Device check-box.

shropshirelad
Posts: 44
Joined: 24 Jun 2015

19 Jul 2017

I seem to have sorted this by doing a very obvious thing - I replaced the USB cable that I'd been using for the last couple of years and...hey presto, it's all playing nice again!

Post Reply
  • Information
  • Who is online

    Users browsing this forum: Bing [Bot] and 9 guests