ReCycle on High Sierra

This forum is for anything not Reason related, if you just want to talk about other stuff. Please keep it friendly!
Post Reply
User avatar
Marco Raaphorst
Posts: 1467
Joined: 22 Jan 2015
Contact:

12 Oct 2017

ReCycle cannot be used on Apple's latest OS High Sierra. Is it a dying product? I love ReCycle but not being able to upgrade to High Sierra feels weird.

Have tried to find out if the Props are considering updating ReCycle but didn't receive an answer (yet).
Marco Raaphorst

Music & soundware https://melodiefabriek.com.
Check out my new ReFill Rockmen: https://melodiefabriek.com/blog/rockmen ... available/

User avatar
theshoemaker
Posts: 369
Joined: 21 Nov 2015
Location: Germany
Contact:

12 Oct 2017

Marco Raaphorst wrote:
12 Oct 2017
ReCycle cannot be used on Apple's latest OS High Sierra. Is it a dying product? I love ReCycle but not being able to upgrade to High Sierra feels weird.

Have tried to find out if the Props are considering updating ReCycle but didn't receive an answer (yet).
ReCycle is most likely 32bit ... on the Props site they show a release date of 2013 .... High Sierra dropped support for 32 bit in a rush .. Can't understand that decission, as well as with the iOS stuff. Anyway, until props don't port and compile to 64bit this won't work.
:PUF_figure: latest :reason: V9 on MacOS Sierra

User avatar
FlowerSoldier
Posts: 298
Joined: 03 Jun 2016

12 Oct 2017

Wow. Suddenly, I'm pleased my High Sierra installation failed. I would have been pretty upset to find out ReCycle was obsolete. Is there a way to run it in 32-bit mode?
64-bit only seems a little extreme...but Apple has their own way of doing things.

User avatar
moneykube
Posts: 938
Joined: 15 Jan 2015

13 Oct 2017

noticed 500 bucks of video software from apple no longer works(my version of compressor and final cut pro) and you have to purchase again for continued use on high sierra... and a few others... not upgrading...
and recycle ! ... wow... not too impressed with apple these days

User avatar
theshoemaker
Posts: 369
Joined: 21 Nov 2015
Location: Germany
Contact:

13 Oct 2017

I have to apologise ... false assumption. Here is my proper research:

from https://www.propellerheads.se/download/ ... et_article
ReCycle 2.2 Fix List

The program is now compatible with 64 bit operating systems.
So it seems like it's just some other incompatibility.
:PUF_figure: latest :reason: V9 on MacOS Sierra

User avatar
moneykube
Posts: 938
Joined: 15 Jan 2015

13 Oct 2017

"The following products are still being tested, so don’t upgrade to macOS High Sierra if you intend to use these products until a full compatibility statement is available from Propellerhead:

ReCycle 2.2.4

The following products are NOT compatible with macOS high Sierra:

Reason 9.5.1 and earlier
Reason Essentials 9.5.1 and earlier
Reason Limited 1.5.3 and earlier"
https://www.propellerheads.se/support/n ... gh-sierra/

so still checking it seems

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 4 guests